Tux Guitar


Subject no sound in ubuntu 8.10

Author Message
Post: Dec 5th 2008 at 10:04 PM

hi everyone.
i just installed tuxguitar on my ubuntu 8.10 and tried to play a gp3 file but there is no sound.can anyone here help me out? i've read some of the threads here but can't find any solution.

Back to Top
Post: Dec 9th 2008 at 7:42 AM

Hi. I'm using 8.04, and having relatively no problem.
It should be the same for you.
When i WAS having problems, it was because i was running VirtualBox at the same time, and it (or its guest operating system) was stealing the output device.

I would first close all other applications and try again.
If you've already tried this, my next question is 'what have you done about pulseaudio'?

I am not personally intimate with the state of pulseaudio in Intrepid (i simply didn't upgrade because they hadn't moved to the glitch-free version of it yet), but there are a few guides out there which can solve your sound problems for most applications. Do you have problems with other sound applications? Maybe it is your pulseaudio setup.
Here is one pulse guide that helped me:http://ubuntuforums.org/showthread.php?t=770213&page=4

If that is not your problem. Then I do not know.
I've also had lots of problems with other sound applications recently, which i've yet to solve. They were also note editing type applications, and tuxguitar was the only one i'd found to work at all!

Back to Top
Post: Dec 9th 2008 at 10:18 AM

Joe, did you installed tuxguitar from ubuntu repositories ?
if yes, is tuxguitar-jsa, tuxguitar-alsa, or tuxguitar-fluidsynth installed ?

What MIDI Port, MIDI Sequencer do you have selected on tuxguitar ?

The problem that Sean describe, is a nown problem of java sound api (used by tuxguitar-jsa) that uses OSS output.
some users can solve it by running tuxguitar with alsa-oss:
aoss tuxguitar

Sean, I've tested pulseaudio on intrepid, and it seems to be better.
i've tested it under hardy, and fluidsynth didn't work, timidity had problems.
now both synths work without problems.
also, for OSS applications (java sound api again)
there is something like the "aoss" for alsa..
it's "padsp" command. that capture /dev/dsp (where OSS capture sounds) and wrape it to pulseaudio libraries.

Back to Top
Post: Dec 12th 2008 at 11:01 PM

actually i'm kinda new with ubuntu..i dual boot ubuntu and xp on my laptop.
yes, i did install tuxguitar thru ubuntu repo.
the MIDI Sequencer only got 1 choice which is Tuxguitar Sequencer..no other options.
the MIDI Port got 2 choices which are Midi Through Port-0 [14:0], and Midi Through Port-0 #0..i've tried changing the midi port but still didn't work..
(if yes, is tuxguitar-jsa, tuxguitar-alsa, or tuxguitar-fluidsynth installed)--> all are installed..

Back to Top
Post: Dec 13th 2008 at 1:43 AM

If you have installed tuxguitar-jsa, you should have "Real Time Sequencer" option available for MIDI Sequencer.
Is it enabled ?
See at Tools -> Plugins, let me know the Java Sound Api plugin status.

also please copy me the result of this line:
tuxguitar -i

About midi ports,
"Midi Through Port-0" is an alsa port that never play sounds as default. (you see it twoice because you have alsa and oss plugin installed, so they list same port)
Try install timidity:
sudo apt-get install timidity

This is a software synthesizer, you should able to select it on MIDI Port after install it.

Back to Top
Post: Dec 13th 2008 at 1:35 PM

I Had the same Problem.
sudo apt-get install timidity,
and selecting it on MIDI Port did it for me.

Thanks very much!

Back to Top
Post: Dec 13th 2008 at 11:16 PM

hi guys..
thanx a lot Julian..after i installed the timidity and selected it, i can play gp files with sound..haha..so excited now..thanx a lot guys!!

Back to Top
Post: Dec 22nd 2008 at 3:45 PM

Yep, this sorts the problem for me too.


Back to Top
Post: Dec 24th 2008 at 3:40 AM

I was having the same problem. Installing timidity worked for me. Thanks Elrond.

Back to Top
Post: Dec 24th 2008 at 7:24 PM

I recevide my copy of ubuntu yesterday through the mail and my sound is not working. I can faintly here songs play and i can faintly here static when I use the command $ sudo cat /dev/urandom > /dev/dsp. Yes the mixer including the root mixer is unmuted and turned up. Ive tried several solutions and none have worked. Help!

Back to Top
Post: Dec 25th 2008 at 7:51 PM

i don't think "cat /dev/urandom > /dev/dsp" may help..
/dev/dsp is an OSS device.. while tuxguitar can run under ALSA instead, by other hand, this is an "Audio" device and tuxguitar looks for "MIDI" devices.
on OSS case, its /dev/sequencer instead of /dev/dsp.
then each device may use /dev/dsp to play final sounds or not.

The question is if you installed tuxguitar from ubuntu repositories.. did you installed tuxguitar-jsa and/or tuxguitar-alsa ?
What "MIDI Ports" do you have available to select on tuxguitar ?
do you have timidity or fluidsynth installed and running ?

Back to Top
Post: Jan 4th 2009 at 4:52 AM

Another fixed sound problem with Timidity. Thanks!

Back to Top
Post: Jan 5th 2009 at 1:50 AM

Timidity has given me sound, but the tempo lags and skips. Is that just the nature of routing the midi synthesis trough a different application? Can I do something with Jack to reduce latency?

Back to Top
Post: Jan 5th 2009 at 10:18 PM

Actually, I think Jack is causing my problems instead of offering a solution. Never mind, I'll figure it out.

Back to Top
Post: Jan 6th 2009 at 9:00 PM

I have follow everything and still it wont work!

I have install tuxguitar-jsa, tuxguitar-alsa, or tuxguitar-fluidsynth and timidity is already installed

this is what I have tuxgauitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.27-9-generic
-> JVM-Name: Java HotSpot(TM) Client VM
-> JVM-Version: 11.0-b15
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_10
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-6-sun-
-> Java-Class-Path: :/usr/share/tuxguitar/:/usr/share/tuxguitar//tuxguitar.jar:/usr/share/java/itext.jar:
-> Java-Library-Path: /usr/lib/jni

Still I have no sound coming from it :(

Back to Top
Post: Jan 6th 2009 at 9:30 PM

I got it fix now Thanks to

Ubuntu forum

Back to Top
Post: Jan 22nd 2009 at 1:34 PM

I istalled timidy and Tuxguitar is going, thanks

Back to Top
Post: Feb 9th 2009 at 8:34 AM

Personally, I got no sound until I installed BOTH the jsa package and the alsa package for tuxguitar(had alsa installed from the get go along with timidity and a few soundfonts)

Back to Top
Post: Feb 13th 2009 at 3:48 PM

timidity does not help, I have same proble like other them... pls help me.

Back to Top
Post: Mar 28th 2009 at 9:13 PM

I have timidity, and my tuxguitar still not playing any sound, and i want to know how can i put the letters in the guitar scale there're some blue balls...

Back to Top
Post: Mar 28th 2009 at 9:25 PM

Hey guys, i choose the "TiMidity port 0 #1" it plays, but on the chords it plays too slow and doesn't sounds right, it have some kind of bugs, i dont know if this is my PC, or the program, i'm still testing which one goes right...

Back to Top
Post: Mar 31st 2009 at 6:01 AM

thank you fixed with timidity

Back to Top
Post: Apr 2nd 2009 at 1:27 AM

i still needing some help, i'm thinking about delete it and re install later...

Back to Top
Post: Apr 2nd 2009 at 11:16 AM

If timidity isn't a good option for you, you can test fluidsynth, that is another software synthesizer.

fluidsynth don't have a startup script under debian/ubuntu as timidity have.
so you need to manually run it:
fluidsynth YourSoundFont.sf2

Back to Top
Post: Apr 3rd 2009 at 6:52 PM

Now It works"!!!!!
But i didn't understand what you would say julian, i just chose th eJAva Sound synthethizer, and it works normal!!

Back to Top
Post: Apr 14th 2009 at 3:46 PM

My tuxguitar not work yet, i install timidity but it not sound, help me please....

Back to Top
Post: Apr 22nd 2009 at 4:05 PM

hi everybody, I installed Tuxguitar and I don't get sound at all.

I have Linux Mint

Thanks again!

Back to Top
Post: Apr 22nd 2009 at 4:47 PM

I fix it.... I post the same problem in the past... must be some kinda click here.

Back to Top
Post: Jul 28th 2009 at 11:11 PM

ohh thanks a lot ..

Back to Top
Post: Aug 5th 2009 at 6:49 PM

With Timidity you have to run it... try 'timidity -iA -Os' in the terminal when Timiditys installed. You'll have to do that every time you open Tuxguitar.

Back to Top
Post: Nov 22nd 2009 at 7:45 PM

I tried the timidity solution, I still have no sound. Any other suggestions?

Back to Top
Post: Nov 23rd 2009 at 7:41 PM

Since pulseaudio existense, i think that timidity is not the best choice (just my opinion) to configure MIDI under GNU/Linux.
In my opinion fluidsynth (supports pulseaudio, alsa, jack, etc.. ) is the best option.

If you have tuxguitar 1.2, you could try the tuxguitar-fluidsynth plugin, with pulseaudio output. and using a buffersize between 1024 and 2048..

if you have a lesser version of tuxguitar, i don't suggest the plugin ( you can't configure the buffer size )

but you can try downloading qsynth.. configure the buffer size.. and then select it in tuxguitar.

Maybe a big difference between timidity and fluidsynth for users, is that debian packages made a startup script for timidity, so you don't have to configure anything..
but there is no a startup script for fluidsynth package.
so you have to manually create it, or start fluidsynth, every time.. and manually download and configure a soundfont file.

Back to Top