Tux Guitar


Subject System hangs on 'PLAY' command

Author Message
Post: Nov 11th 2008 at 8:57 PM

Hi all, I sent this post yesterday in the wrong section too ('Help'): I apologize for the mistake...

I downladed the windows version of TG, but when I try to play the song the system hangs and the only way to get out is to restart the whole system via reset button on PC.

It happens either using the toolbar 'play' button or the 'PLAY' command on menu too; it seems not to depend on having loaded music file or not. Placing notes on the staff I get the sound of the note, but when I try to play the song (even if it's a blank song or just the few notes i put on the staff) the system hangs. Load meter stays low, after reboot i can find no sign of the hang on eventwvr.msc: no clues, no nothing.
I tried to change the audio device settings in TG too, but still no result.

The system is a WinXP SP2 on the following hardware:
MB asus P5GC-MX/1333; bios AMI 0312
CPU intel 2180 (dual core)
RAM 2048MB (single bank / single channel)
HD maxtor 320GB; the SO resides on a 20 GB partition at the beginning of the disk.
Th audio device is a turtle beach montego II with aureal chip; the MB internal sound device is disabled on bios setup. All the hardware resources are running fine (no error nor warnigs).

Does anyone have some idea about it?

I also have Ubuntu 8.10 installed in another partition: I'm planning to try on it too...

Thanks in advance for the aswers; sorry for long post.
(I apologize for any mistake you might find in the text: I'm not english...)


Back to Top
Post: Nov 13th 2008 at 11:08 AM

If you listen sounds when you add a note, so i don't think it's a sound problem..
maybe it crash when you click play because something wrong on the sequencer.

What "MIDI Sequencer" do you have selected on Sound options ?
Did you test change it ?

What version and package of tuxguitar did you downloaded ?
e.g of version: 1.0
e.g of package: Windows-x86 Excelsior JET Native Release

See here for these options that i mean:

Back to Top
Post: Nov 14th 2008 at 3:31 AM

Hi, on the 'settigs' menu I can choose 'real time sequencer' and 'TuxGuitar sequencer', unfortunately with same results.

The program version is 1.0
the installer is the BitRock:
Have java 6 update 7 installed too (by OpenOffice setup, I suppose).

I'm trying to download the JET native release, but download hangs (!) at 95%...:(


Back to Top
Post: Nov 14th 2008 at 10:52 AM

Finally I dowloaded the JET native release.
It hangs too, exatly as before.



Back to Top
Post: Nov 14th 2008 at 11:44 AM

No i don't think the problem is the "package"..
i asked you this.. just to give you some steps to test something.

Try go to where tuxguitar (bitrock version) is installed.
Often "C:/Program Files/tuxguitar-xxxx/"

On this installation folder there should be a file called "tuxguitar.bat"

Try open this file with "wordpad".

On the file, the second line (i think)
start with: "javaw".. try replace this "javaw" to "java"

Save the file, and make 2 click to it. ( not the .exe.. just tuxguitar.bat ).

Now tuxguitar should start with a windows shell.

Then, try reproduce the error, and let me know if some error text appear on this windows shell.

If you see something.. please paste here "all" the text you see on this shell.

Back to Top
Post: Nov 14th 2008 at 3:59 PM

Hi, thanks for help; unfortunately the problem remains...

I ran tuxguitar.bat, after your suggested modify; in the resulting windows shell appears the two separate commands (tuxguitar and java invocation) of the batch file, as follow ('Programmi' stands for 'Program Files'):

C:Programmituxguitar-1.0>cd "C:Programmituxguitar-1.0"

C:Programmituxguitar-1.0>java -cp ;tuxguitar.jar;libswt.jar;libitext.jar;sha
re -Djava.library.path=lib org.herac.tuxguitar.gui.TGMain 0
(I hope the lines aren't broken. I apologize if so...)

When I hit 'Play' the system hangs, but nothing else appear in the console...
I find that numlock and caps lock in the keyboard are frozen too when the PC hangs: they don't change state (led on-off) if I hit them; it seem the problem propagates at low level (bios?) in the machine, but not enaugh to lock the video card too (the display is frozen, but still on) or to cause a sistem reset.
I have no idea on how I can get some clue; maybe trying on Ubuntu (same PC), could reveal if it's an hardware problem?

Thanks anyway. :)



Back to Top
Post: Nov 14th 2008 at 6:34 PM

Installed tuxguitar on Ubuntu 8.10. I can play the songs with no problem (no hangs), but I can get no sound...
But this is OT here and I'm sure I have seen something about it in the forum: i'm going to look for :)

In Windows I'm going to try anoter (different brand/model) audio card.



Back to Top
Post: Nov 15th 2008 at 10:24 AM

How did you installed it under Ubuntu ?
If you installed it from ubuntu repositories,
make sure to install: tuxguitar-jsa and tuxguitar-alsa.
try install timidity too. Then, go to settings and select a Timidity Port.

About the problem under windows.. it's to hard understand what happen if there is no error log.. but i don't think it should be something with your sound card.
If you listen sounds when you add a note, so sound card is running fine.

There are steps before play, like "make the midi song" in background..
to know if it's causing problems, you can try:
File -> Export -> Export MIDI. instead of play the file.

Does your system hand when you export the file ?

Back to Top
Post: Nov 17th 2008 at 12:56 PM

I installed it Under Ubuntu via Synaptic. It asked me for some more packet; I don't remember exactly what, but I agreed and installed them too: i'll verify.

On Windows I still can get no information about the crash: the midi file export works fine, and I can play the resulting file on windows media player.

In an attempt to solve the problem I updated the PC to the latest drivers, and I upgraded the bios at the latest version (0407) too, but no change.
I also ran a memtest last night, but no errors. So I'm looking for some debug tool to get information (and recover it after the hang and nedeed reboot) about the cpu/mem/peripherial usage when using the program...


Back to Top
Post: Nov 17th 2008 at 7:14 PM

Hi, finally it runs!

I de-installed and removed the TBS Montego sound card, Bios-reactivate the internal audio device and reactivated under device manager: everithing works fine.

Maybe a driver problem? I don't know. I'm going to investigate and post here the results (if any)...

Thanks for support and help.


Back to Top
Post: Dec 1st 2008 at 3:23 AM

Don't know if this will help any of you, but it seemed to work for me. Install the tuxguitar-java and simply switch the MIDI port in preferences to Java Sound Synthesizer

Back to Top