Tux Guitar


Subject TuxGuitar doesn't start, 100% CPU, no errors

Author Message
Post: Nov 1st 2008 at 11:47 AM

Hi Everyone,

I'm trying the -jet and -linux-x86 versions of TuxGuitar. When I run them, "something" rapidly flashes on the screen, the CPU goes to 100% and nothing happens. No messages are shown on the terminal.
Tried root and non-root, JVM 1.6.x and 1.5.x .
Any ideas?

thanks for helping out,

(here are the last lines output from "bash -x tuxguitar")

+ export CLASSPATH
+ /etc/java-config-2/current-system-vm/bin/java -Xms128m -Xmx128m -cp :.:/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/jdbc/lib/classes12.zip:./tuxguitar.jar:lib/swt.jar:lib/itext.jar:share/ -Dtuxguitar.share.path=share/ -Djava.library.path=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib:/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib32:lib/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/mozilla org.herac.tuxguitar.gui.TGMain '' ''


# ./tuxguitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.24-gentoo-r8
-> JVM-Name: Java HotSpot(TM) Server VM
-> JVM-Version: 10.0-b23
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_07
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /opt/sun-jdk-
-> Java-Class-Path: :.:/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/jdbc/lib/classes12.zip:./tuxguitar.jar:lib/swt.jar:lib/itext.jar:share/
-> Java-Library-Path: /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib:/usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib32:lib/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/mozilla


# ./tuxguitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.24-gentoo-r8
-> JVM-Name: Excelsior JET
-> JVM-Version: 1.6.0_03
-> JVM-Vendor: Excelsior, LLC
-> Java-Version: 1.6.0_03
-> Java-Vendor: Excelsior, LLC
-> Java-Home: /home/aragorn/temp/tuxguitar/tuxguitar-1.0-jet/rt
-> Java-Class-Path: tuxguitar.jar:tuxguitar-alsa.jar:tuxguitar-ascii.jar:tuxguitar-browser-ftp.jar:tuxguitar-compat.jar:tuxguitar-gtp.jar:tuxguitar-jsa.jar:tuxguitar-lilypond.jar:tuxguitar-midi.jar:tuxguitar-musicxml.jar:tuxguitar-pdf.jar:tuxguitar-ptb.jar:tuxguitar-tef.jar:tuxguitar-converter.jar:swt.jar:/home/aragorn/temp/tuxguitar/tuxguitar-1.0-jet/share
-> Java-Library-Path: /home/aragorn/temp/tuxguitar/tuxguitar-1.0-jet/lib

Back to Top
Post: Nov 1st 2008 at 1:30 PM

hmmm, it will not easy to understand the problem if there are no errors :(

try manually run it.
1_ go to where tuxguitar-linux-x86 is installed.
2_ exec:
java -cp tuxguitar.jar:lib/swt.jar org.herac.tuxguitar.gui.TGMain

If there is something on the terminal after exec it, please paste me all here.

After crash, take a look if a new log file was created on the current folder (JVM make log files when it crash because some native library problem).
If you found a new log file paste all content here please.

Back to Top
Post: Nov 2nd 2008 at 12:45 AM

Hi Julian, thanks for answering.

Sadly no output (after a while I pressed CTRL-C)

aragorn@balrog ~/temp/tuxguitar/tuxguitar-1.0-linux-x86 $ java -cp tuxguitar.jar:lib/swt.jar org.herac.tuxguitar.gui.TGMain
^Caragorn@balrog ~/temp/tuxguitar/tuxguitar-1.0-linux-x86 $

strace seems not to log anything useful:

aragorn@balrog ~ $ strace -o out.txt -p 8177
aragorn@balrog ~ $ cat out.txt
futex(0xb7dd8bd8, FUTEX_WAIT, 8181, NULL) = ? ERESTARTSYS (To be restarted)
--- SIGINT (Interrupt) @ 0 (0) ---
futex(0x66ae9c0, FUTEX_WAKE, 1) = 1
rt_sigreturn(0xb7dd8bd8) = 240
futex(0xb7dd8bd8, FUTEX_WAIT, 8181, NULL) = ? ERESTARTSYS (To be restarted)

thanks for your help,

Back to Top
Post: Nov 2nd 2008 at 11:49 AM

Ok, i don't want to say false things.. i really don't have idea what is happening :).

the only thing that i can think may be the problem now is SWT on your platform.
it say this because i saw that you could exec "tuxguitar -i".
so, this means java worked without problems.

So let me know, so you have tested any other SWT based application ? such as eclipse, azureus..

Is it the first time that you try tuxguitar ??
i mean, did other version of tuxguitar worked for you ?

You can try download a latest version of SWT ( 3.2, or 3.3 )

extract the downloaded .zip file and copy "swt.jar" to "/temp/tuxguitar/tuxguitar-1.0-linux-x86/lib/swt.jar"

if your downloaded version is "3.2", also copy *.so from extracted file to "/temp/tuxguitar/tuxguitar-1.0-linux-x86/lib/"

Or if maybe Gentoo distributed SWT, you can test use gentoo's package.
so if it exists, you should check where "swt.jar" is, and where all *.so of SWT (often on /usr/lib/jni on allmost distributions)
and modify the launcher script to set these paths:
Where: -cp lib/swt.jar
and where: -Djava.library.path is setted.

Another posibility is that any plugin may causing problems.
you can try rename:

So tuxguitar will not found any plugin to load.

I hope something of this helps.

Back to Top
Post: Nov 2nd 2008 at 11:58 AM

Here there is a jnlp (Java Web Start) file to test SWT controls.

If your browser don't try to open it with java,
so you can run it on a terminal:
javaws http://www.eclipse.org/swt/jws/controlexample.jnlp

Let me know please if it worked.

Back to Top
Post: Nov 3rd 2008 at 3:16 PM

Hi Julian,

yes, it seems that I'm not able to launch any SWT application. Symptoms are the same (100% CPU load, no errors).

No luck with:
javaws http://www.eclipse.org/swt/jws/controlexample.jnlp

And with:
wget http://www.eclipse.org/swt/jws/swt-gtk-linux-x86.jar
wget http://www.eclipse.org/swt/jws/controlexample.jar

java -cp swt-gtk-linux-x86.jar:controlexample.jar org.eclipse.swt.examples.controlexample.ControlExample

java -cp /usr/share/swt-3/lib/swt.jar:controlexample.jar org.eclipse.swt.examples.controlexample.ControlExample

(the latter should use Gentoo's provided SWT)

Any other ideas? (I should check Gentoo/SWT bug databases)

Thanks for your help,

Back to Top
Post: Nov 3rd 2008 at 6:27 PM

On Gentoo, you allways build packages from sources, true ??

If not, i would try to build SWT native libraries ( *.so ).
I think there should be a problem there.

i think that java is diying when SWT try to load the native library. but without any error log it's very hard to know if this is true, and the reason of this.

does your user have read/write access to /tmp folder ?
since 3.3 SWT (official release) attempt to get all *.so files from swt.jar, write them to /tmp folder and then load them.
I don't think it can be the problem... but just to be sure.

Back to Top
Post: Nov 3rd 2008 at 9:37 PM

Hi Julian,

yes, Gentoo provided packages are being built from source... I also confirm that my user can read/write from /tmp (and besides that I also tried running stuff from root).

I guess I should ask to SWT or Gentoo people about my issue. Meanwhile, many many thanks for your patience and time.


Back to Top
Post: Nov 4th 2008 at 12:13 PM

Please let me know if you find something about.. it may be usefull for other users..

At last, i can think a last alternative of the problem.
maybe problem is not at JNI (java native library) itselft,
but there is a problem with some specific libraries.
tuxguitar (gnu/linux version) as default is distributed with SWT for "GTK"..
do you have GTK libraries installed ??

there is another SWT version for GNU/Linux that uses Motif libraries.
it may work if you install motif libraries.. but it's not so nice.. you can test if it works.

Back to Top
Post: Oct 11th 2009 at 3:02 AM

TuxGuitar doesn't start, no available JVms

Back to Top
Post: Oct 11th 2009 at 7:37 PM

Brian, you have to install java

Back to Top