Tux Guitar


Subject No sound on Fedora 9/x86_64

Author Message
Post: May 2nd 2008 at 11:31 AM


I don't get any sound on F9/x86_64 and I don't get any errors either. I'm using the binaries from tuxguitar-1.0-rc3-linux-x86_64.tar.gz. I checked that the alsa plugin is turned on in the settings. I also tried both the real time and the tuxguitar sequencer. snd_seq is loaded and I alsa output seems to be orking fine (tested with mplayer -ao alsa).

Maybe the current openjdk 1.6 that ships with F9 doesn't emit any errors/wanring anymore about missing sound synthesis, but still doesn't work? Does that mean I need to install Sun's jdk in parallel?


Back to Top
Post: May 2nd 2008 at 12:28 PM

> alsa output seems to be orking fine (tested with mplayer -ao alsa).
MPlayer uses "Audio" output, while tuxguitar-alsa use MIDI output.
the correct test would be:
aplaymidi --port [midi_port] file.mid

I think the problem is your Midi Port.
do you have any software synthesizer installed ? ( like timidity or fluidsynth )

try exec "aconnect -o" it'll give you a list of midi ports connected to alsa.
Waring: "Midi Through Port-0"

Back to Top
Post: May 2nd 2008 at 7:50 PM

Thanks Julian!

indeed I was sending the output to some port 0 (which seems to be some kind of /dev/null in midi language?). After starting timidity I had more options and the first one worked (I haven't tried fluidsynth yet, but I guess it would work the same)!

I still need to learn a couple of things about midi, thanks for helping, and thanks for tuxguitar in the first place!

Back to Top