Tux Guitar


Subject tuxguitar does not start ubuntu 8.04

Author Message
Post: Apr 24th 2008 at 6:23 PM


I have just installed tuxguitar on the brand new Ubuntu Hardy Heron.

With pleasant surprise I found it in the add/remove list!

But, now that I have installed it, when I click on the icon (from the audio-video menu) nothing happens. Simply nothing. What could the reason be?

Back to Top
Post: Apr 24th 2008 at 8:43 PM

what does happen if you start it inside a terminal (Alt+f2 there enter xterm and there tuxguitar)

you can mark it with the mouse and paste it with the middle mouse button into this forum

Back to Top
Post: Apr 24th 2008 at 8:49 PM

Thank you I just solved the problem I had to install java!!

Sorry guys :)

and congratulation to the team for this achievement!

Back to Top
Post: Apr 24th 2008 at 8:59 PM

giovanni, as i know, ubuntu hardy included tuxgutiar 0.9.1.( 1 year older version )

By other hand, if you needed to install java. i suggest you report it as bug to ubuntu tuxguitar package.
because it should be a "dependency" of tuxguitar.

Back to Top
Post: Apr 25th 2008 at 8:24 AM

Maybe becouse java is in that restricted repostitory it doesn't get installed by default?
becouse it depend on java : http://packages.ubuntu.com/hardy/tuxguitar

Back to Top
Post: Apr 25th 2008 at 11:43 AM

it depends on java, you are right.
but, as i see, tuxguitar is on "multiverse" repository ( same as "sun-java6-jre" ). so if he could install tuxguitar, he had multiverse enabled..
Maybe the problem was configure java ( update-alternatives --config java ) instead of install it.

Back to Top
Post: Apr 25th 2008 at 1:09 PM

I dont know guys I installed java and ten it worked. i installed tux from the add/remove list and java from synaptic. i didnt do anything else. i am a real newbie.

But i noticed that tux gui was different from before bt i thought it was because it was newer version now u tell me it is older!! in fact i tried a gp.5 and it doesnt read it! what should i do?

i dont know how to report bugs but i would do it with pleasure if u explain me how.

Back to Top
Post: Apr 25th 2008 at 1:38 PM

0.9.1, don't have support for GP5 (v5.10) files.
So that isn't a bug.. it just not supported on that version.

By other hand.. ubuntu ( or any other distribution ) package mantainers, only fix "package" bugs. ( dependencies, run scripts, etc ).
but not tuxguitar-0.9.1 known bugs.

> what should i do?
You are a free man.
you can choice to install latest version. or keep older.
but ofcourse, with "older" version you will not able to see new features/bug fixeds.

Back to Top
Post: Apr 25th 2008 at 5:04 PM

ok i was asking for a suggestion :)

if i keep the older version will it ever upgrde to the newer one?

Back to Top
Post: Apr 25th 2008 at 5:30 PM

mmm wait.
We are not "ubuntu" developers. so we don't take desitions about ubuntu repository/packages

We are only tuxguitar developers, and "somebody" ( we didn't ) was who added tuxguitar-0.9.1 to ubuntu repository

What i mean is, we can't know if/when/how/why ubuntu will upgrade the tuxguitar package.

You should ask this questions to ubuntu developers:
# Web site

# TuxGuitar ubuntu package

Back to Top
Post: Apr 25th 2008 at 6:05 PM

thank you very much

I will ask the italian comunity if there is something we can do on the bar of ubuntu-it.org

Back to Top
Post: Apr 25th 2008 at 6:08 PM

I downloaded and installed TuxGuitar-1.0-rc3 instead ubuntu's dist. Works fine!

Back to Top
Post: Jun 23rd 2008 at 12:32 PM

Hi, I had absolutely same situation with Ubuntu 8.04 today :)
No java automatic installation. Fortunately there is this site and I understood what's wrong, thanks :)

Back to Top
Post: Jun 27th 2008 at 10:52 PM

Unfortunately the noob here doesnt know what java you are talking about, is it the "java-package" in the synaptic?

Many thanks

Back to Top
Post: Jun 28th 2008 at 11:31 AM

Hi all,

I tried installing the sun-java5-jre as described in the documentation: http://www.tuxguitar.com.ar/tgwiki/doku.php?id=doc:install_ubuntu

Buuttt, it didnt work )c:
When i try to run it from the terminal, i get the following:

Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

Any clues?

Back to Top
Post: Jun 28th 2008 at 2:16 PM

Hi, if you are runnig tuxguitar from ubuntu repositories,
please paste here the content of /usr/bin/tuxguitar (open it with any text editor), so that will be the only way to know how that package was builded.

By other hand, try to exec on a terminal:
sudo update-alternatives --config java

And select the java 1.5 from sun.

Back to Top
Post: Jul 1st 2008 at 5:11 PM


If i download the sun-java6-jre in instead of the 5 it works fine... it'd be good if you guys could update the documentation

Anyway, GREAT application!

Back to Top
Post: Jul 2nd 2008 at 7:40 AM

Where did you read that it doesn't work on Java6?
Java5 is recommended, Java6 is only newer/better.

Back to Top
Post: Jul 2nd 2008 at 10:48 PM

Mr_Noob, you followed instructions to install tuxguitar dependencies here, but you downloaded tuxguitar from another place.
"java.lang.UnsupportedClassVersionError" means you are running a java application with a "lesser" java version than used to build it.
while all files available to download here, was builded with 1.4 class target. so, there is nothing wrong in java version at documentation.

Back to Top
Post: Aug 23rd 2008 at 11:04 AM

Hi please help I tried everything from above and still the tuxguitar doesn't start

Back to Top
Post: Aug 23rd 2008 at 2:02 PM


> I tried everything from above
What exactly things did you try

What tuxguitar version did you installed ???
and where did you get it ?

Back to Top
Post: Aug 24th 2008 at 6:49 PM

The reason why the Ubuntu Hardy package doesn't install jre automatically is because Ubuntu Hardy uses the GNU JRE (gcj) by default, because it conforms better with the Ubuntu philosophy. But the fact that the package doesn't work with gcj by default is very weird...

Maybe it would be enough to edit a little bit the executive script. But I don't know what should I change there. I tried to put the path I use with OpenOffice, instead of JAVA_HOME, but then I get a permission issue, permission denied. I tried to run tuxguitar with sudo, but I get the same message again, and the app still doesn't run...

Now I unistalled that package and will try to download from here.

Back to Top
Post: Aug 24th 2008 at 7:08 PM

OK, I installed from the ubuntu package available from this website. Now it runs, but it says it cannot load java sound api... :-/
Wouldn't timidity (alsa) be better than java for midi playback in GNU/Linux? But I must confess I am not very familiar with java...

Back to Top
Post: Aug 24th 2008 at 7:27 PM

> it cannot load java sound api
As you told on your previous post, the problem maybe GCJ (it don't implements javax.sound package at all)

But yes, you can play sounds throught alsa.
TuxGuitar-jsa (java sound api) and TuxGuitar-alsa are only plugins.
If you don't want to see the java sound api error anymore you can go to Tools -> Plugins and disable the plugin.

If you want to play sounds with timidity, so go to Tools -> Settings, and on Sound option make sure "Timidity Port 128:0" is selected on MIDI Port option.

Back to Top
Post: Aug 24th 2008 at 8:29 PM

That's exactly what I did, and now it works just as it should. :-) Thank you very much!

It is weird to have a plugin that doesn't work set as default, though... Maybe the Ubuntu package should be compiled to work with alsa by default?

Anyway, the "problem" is very easily solvable. So, it's good enough for me. The application itself seems to work just fine.

Thank you a lot for developing such an application!

Back to Top
Post: Aug 25th 2008 at 10:55 AM

> Maybe the Ubuntu package should be compiled to work with alsa by default?
Well it works with alsa as default ( just see that Alsa plugin was installed by default)

But we can't set a "timidity" port as default because not everybody have timidity installed.

Back to Top