Tux Guitar


Subject Tuxguitar on ibook G4??

Author Message
Post: Jan 8th 2008 at 1:08 PM

I have a ibook G4 and i tried to download Tuxguitar 0.9 for MacOS.

Now i see that I have it on my computer but I can't open it when i click on it. Why???

Back to Top
Post: Jan 8th 2008 at 1:28 PM

Do you have Java installed ??

Back to Top
Post: Jan 11th 2008 at 3:02 PM

Julian: all macs have Java by default.

meee: what is your OS X version? also what happens when you double-click?

Can you try running it from terminal (right-click TG, select show package contents, open Contents/MacOS. Then open Terminal from the Utilities directory, and drag and drop the 'tuxguitar' executable onto the terminal window and press enter)

Back to Top
Post: Jan 22nd 2008 at 10:49 AM

Hey im trying to download TB for a G4 powermac running 10.3.

When i double click the icon it bouces in the dock but then dissappears..

I tried the terminal option as suggested above and i got this :

Last login: Wed Jan 23 00:16:30 on ttyp1
Welcome to Darwin!
iJames-Computer:~ ijames$ /Volumes/tuxguitar-0/tuxguitar-0.9-mac.app/Contents/MacOS/tuxguitar
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/herac/tuxguitar/gui/TuxGuitar (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
iJames-Computer:~ ijames$

what do i do now?

Back to Top
Post: Feb 14th 2008 at 8:35 AM

For me it doesn't produce any sound. hmm... I have no problems with windows.

Back to Top
Post: Feb 14th 2008 at 11:54 PM

james: 10.3 has a too old Java version

Marty: weird... anyway next mac version should include a plugin that uses native Quicktime playback so hopefully it would work. otherwise try running from terminal and see if you get an error message, and also post your system version and processor arch

Back to Top
Post: Feb 15th 2008 at 3:07 AM

Hi Auria

Actually I was able to figure out whats the my problem. I am windows user for more than 10 years and now roughly 3 day old mac user :)), so i took me sometime to understand to configure the core audio. I think I used your upload from the repository site.

Anyway am struggling to learn on how to configure this tux guitar a Macbook. I'll just post it to the proper topics. Thanks

Back to Top
Post: Feb 15th 2008 at 11:59 PM

Marty: getting CVS version + building the core audio plugin, with nearly non-existant docs, is programmer's business, not the kind of stuff the average mac/windows users do ;) good job

Back to Top
Post: Mar 13th 2008 at 8:51 AM

Hello Auria,

I'm alos trying to run TG on a G4 iBook (10.3.9).
Is there any way to update Java?

Thanks a lot for your help!

Back to Top
Post: Mar 13th 2008 at 10:14 AM

Paul: latest version of tuxguitar is JRE-1.4 compat.
you shouldn't see "UnsupportedClassVersionError"
is that your error ??

Back to Top
Post: Mar 13th 2008 at 6:31 PM

Oh, I was still trying the 0.9 version...
TG 1.0rc1 works perfectly, thanks a lot!!

Back to Top