Tux Guitar


Subject I have to restart Timidity before using TuxGuitar

Author Message
Post: Dec 21st 2007 at 7:10 AM


First of all: I think this isn't a problem of TuxGuitar itself, but it would be very nice if you could answer me anyway. I've tried some things by myself, looked through the forums here and asked the question in two other forums, but still don't have a solution.

After a reboot, I allways have to restart the timidity-deamon using "sudo /etc/init.d/timidity restart" before the sound works in TuxGuitar. Timidity is running after the reboot, but something (don't know what) doesn't work. There are no error-messages or warnings from TuxGuitar.
Normal Midi-Output with the Timidity-GUI (timidity -ia) doesn't work before or after the service has been restarted. I don't need normal midi-output, but thins seams to be quite strange to me.
A workaround could be a script which restarts timidity a few seconds after the systems started up, but I would rather find a real solution for this problem.
I'm using Ubuntu Gutsy and the newest TuxGuitar package from the download-section here.


Back to Top
Post: Dec 21st 2007 at 8:08 AM

Hi, let me know if i understand:

1* restart timidity
2* run tuxguitar ( sound works )
3* restart tuxguitar ( sound don't work )

is this what happends ???
or you mean you need restart timidity on every Ubuntu Boots ?

> I'm using Ubuntu Gutsy and the newest TuxGuitar package from the download-section here.
i assumed you also have "Tuxguitar Alsa" plugin installed.. isn't it ??

Back to Top
Post: Dec 21st 2007 at 9:03 AM

It's like that:

1. Start computer
2. Start TuxGuitar
--> Sound doesn't work
3. Close TuxGuitar
4. Restart Timidity
5. Start TuxGuitar
--> Sound works
6. Close TuxGuitar and open it again
--> Sound still works

When I restart the computer, the sound is broken again and I have to restart timidity first.

Yes, I'm using the alsa-plugin with timidity and a java-soundbank.

Back to Top
Post: Dec 21st 2007 at 9:23 AM

Ok, know i understand.

but why do you say it's "broquen" ?
are you sure the daemon is "running" when the Os boot ?

try this when you start ubuntu:
ps ax | grep timidity

do you see something like ? :
[PID] ? S 0:00 /usr/bin/timidity -Os -iAD

if you don't is because the daemon is not starting at your init script links..
So you should do this:
update-rc.d -f timidity remove
update-rc.d timidity start 99 2 3 4 5 . stop 99 0 1 6 .

Back to Top
Post: Dec 21st 2007 at 10:39 AM

The process is listed in the graphical system monitor. I'm not sure if the parameters are the same (-Os -iAD), but I ll check it as soon as I'm at home and on my Ubuntu system.

Back to Top
Post: Dec 21st 2007 at 11:23 AM

well if it's listed.. it should be a link to:
/etc/init.d/timidity start

is result of: "aconnect -o" same when your ubuntu boot as when you restart timidity ??

Back to Top
Post: Dec 22nd 2007 at 7:14 AM

Yes, the result is exactly the same:

client 14: 'Midi Through' [type=Kernel]
0 'Midi Through Port-0'
client 128: 'TiMidity' [type=Benutzer]
0 'TiMidity port 0 '
1 'TiMidity port 1 '
2 'TiMidity port 2 '
3 'TiMidity port 3 '

Back to Top
Post: Dec 22nd 2007 at 12:21 PM

mmm, so i don't know what can it be..
maybe any required alsa module isn't load at timidity script start.. ( but i don't think it's the problem because i also have timidity from repositories and this problem don't happends to me )

Back to Top
Post: Dec 22nd 2007 at 1:28 PM

Anyway, thank you for your help!
I'll let you know if I find a solution.

Back to Top
Post: Apr 6th 2009 at 10:35 AM

/etc/init.d/timidity start

Back to Top
Post: Apr 6th 2009 at 1:14 PM

timidity -iA -Os

and paste here all terminal output please.

Back to Top
Post: Apr 7th 2009 at 9:45 AM

thanks for the quick reply...
here the output of timidity -iA -Os

user@vasudha:~$ timidity -iA -Os
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM default
Can't open pcm device 'default'.
Couldn't open ALSA pcm device (`s')

Back to Top
Post: Apr 7th 2009 at 10:46 AM

Do you have pulseaudio installed?

if yes, is your user in pulse audio groups ?
my user have these groups:
audio, pulse, pulse-access, pulse-rt

i added the first line of timidity output on google, and it result in some forums where solution seems to be a "permission" thing.

Back to Top
Post: Apr 17th 2009 at 3:37 PM

I have similar ( or some problems related to timidity and tuxguitar, I get a distorted ( chopped sound) not at all what I was expecting.
ALSA pcm 'default' set buffer size 2048, period size 680 bytes
TiMidity starting in ALSA server mode
Opening sequencer port: 129:0 129:1 129:2 129:3

I have tried playing with the ports as suggested , acn anyone suggest what to do netx

Back to Top
Post: Apr 21st 2009 at 8:06 PM

I had the same problem as posted above. I had to restart timidity each time I wanted to use tuxguitar for it to play midi properly. I was able to fix this issue by following the instructions on the link below. If using firefox just control+f and search timidity. I set it up to start properly upon boot up and to be the default midi player on the machine. Not sure if this will work for everyone but it worked like a charm for me.


I am using ubuntu intrepid 8.1 with a intel HDA sound card if that helps at all.

Back to Top
Post: Apr 29th 2009 at 6:15 PM

Well, after buy a new PC and install debian testing, i could reproduce a similar problem.
it's not easy to determine if we talk about same issue, because there are some different ways to start pulseaudio as default:
* Have it with init scripts ( active it on /etc/default/pulseaudio )
* Have it as autostarted applications ( it's started when you login in your X desktop ).

I have pulseaudio and timidity configured to run on init scripts (for all users, with or without an X desktop ).

after have the problem, i could see that the reason was:
timidity starts before pulseaudio finish load.
i have this scripts order
-> pulseaudio
-> timidity

but when pulse audio script starts, it runs as a daemon.
it means that if inmediatly timidity scripts is executed but on background pulseaudio didn't finish start.

i didn't find a "good" fix for that (also didn't search enought),
but i did a quick fix, not the best, but it works here.
it just make timidity script try 10 times ( wait 1 second for each try )

on /etc/init.d/timidity

i modified the "start" case.
replacing to this:
[ -d /proc/asound ] && [ -d /dev/snd/ ] || {
log_end_msg 1 || echo -n
log_warning_msg "ALSA is not active, cannot start $DESC"
exit 0
log_begin_msg "Starting $DESC..."
for i in `seq 1 10`; do
if [ $ret != 0 ] ; then
if start-stop-daemon ${START} >/dev/null; then
sleep 1
log_end_msg $ret

It works for me.. not sure if it will be usefull for any else..

Back to Top
Post: Jun 5th 2009 at 11:36 AM

Great. It works. thanks a lot. I should learn to do this by myself.

Back to Top
Post: Jun 5th 2009 at 11:32 PM

I found something better...
i think i didn't should post this "quick solution" before be sure...

on PulseAudio page, there is a document "The Perfect Setup"
I did what it says at "Alsa Applications"

just created the file "~/.asoundrc"
with this content:
pcm.pulse {
type pulse

ctl.pulse {
type pulse

pcm.!default {
type pulse
ctl.!default {
type pulse

load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0

And then timidity starts fine..

A little notice, If anybody don't know..
fluidsynth had released a new version.
and it have a native "pulseaudio" driver. so it may be the best solution for play sounds on pulseaudio systems.

Back to Top
Post: Oct 2nd 2011 at 9:39 AM

I could read a book about this wthiout finding such real-world approaches!

Back to Top
Post: Oct 2nd 2011 at 4:41 PM

Rq2kl0 awuwdrnybnyg

Back to Top
Post: Oct 3rd 2011 at 5:33 AM

florida auto insurance 15028 car insurance 8673

Back to Top
Post: Oct 8th 2011 at 9:43 AM

affordable auto insurance 271 cheap auto insurance >:-]

Back to Top
Post: Oct 9th 2011 at 2:24 PM

cheap health insurance rsqad life insurance quotes :-))

Back to Top
Post: Oct 11th 2011 at 1:40 AM

cheap health insurance >:OO auto insurance kqh

Back to Top
Post: Oct 13th 2011 at 4:54 AM

cheap health insurance hwnndq online car insurance =((

Back to Top
Post: Oct 15th 2011 at 5:42 AM

car insureance =DD cheap california auto insurance %((

Back to Top
Post: Oct 17th 2011 at 2:25 AM

car insurance 8OOO business insurance 43204

Back to Top
Post: Oct 20th 2011 at 1:09 AM

car insurance quotes 60853 car insurance jxuul

Back to Top
Post: Oct 23rd 2011 at 12:54 AM

child health insurance uxeiws insurance auto yqdi

Back to Top
Post: Oct 24th 2011 at 12:07 AM

ultram 83056 cialis tadalafil wfk

Back to Top
Post: Oct 25th 2011 at 6:04 AM

florida auto insurance shpum affordable car insurance =-)

Back to Top
Post: Oct 27th 2011 at 6:51 AM

auto insurance quotes 8OO homeowners insurance quotes >:-]

Back to Top
Post: Oct 29th 2011 at 9:20 AM

maryland health insurance plan :-]]] nj car insurance jdsf

Back to Top
Post: Nov 1st 2011 at 8:23 AM

auto insurance quotes jcs life insurance >:-D

Back to Top