Tux Guitar


Subject couldn't start under Ubuntu 7.10

Author Message
Post: Oct 21st 2007 at 2:51 PM

hello Julian,
i installed TuxGuitar-0.9.1 ubuntu package with GDebi Package Installer. but when i click the Tuxguitar icon in the applications menu, nothing happened. how can i fix this ?

Back to Top
Post: Oct 21st 2007 at 3:47 PM

Hi.. try exec "tuxguitar" under a terminal.. and paste here the error message please..

Back to Top
Post: Oct 21st 2007 at 4:04 PM

like this ?
/usr/bin/tuxguitar: line 9: [: /usr/lib/jvm/java-6-sun: binary operator needed (i'm not using a english version, so i translate the error massage here)
/usr/bin/tuxguitar: line 12: [: /usr/lib/jvm/java-6-sun:binary operator needed
/usr/bin/tuxguitar: line 15: [: /usr/lib/jvm/java-6-sun:binary operator needed
/usr/bin/tuxguitar: line 32: /usr/lib/jvm/java-6-sun: it's a directory

Back to Top
Post: Oct 21st 2007 at 4:22 PM

is a problem with the script..
i don't have idea why.. but because line numbers..
the problem is at:
"if [ ! -f ${JAVA} ]; then" lines.. ( of /usr/bin/tuxguitar )

and the script.. can't set the correct java binary file..
so.. try this:

export JAVA=/usr/lib/jvm/java-6-sun/jre/bin/java

if it works.. you can edit /usr/bin/tuxguitar and remove from the first "if" to the last "fi"... and statically set:

Back to Top
Post: Oct 21st 2007 at 4:38 PM

well , it works now ...

thanks so much

eh... if it's not bothers you too much, could you please tell me why this happened to me?

Back to Top
Post: Oct 21st 2007 at 4:49 PM

Hi, i could reproduce the error..
as i can saw on the error log.. you have JAVA_HOME env var setted..

so i tried set it as:
export JAVA_HOME="/usr/lib/jvm/java-6-sun "
and i get the same error.. trying to launch the app..

if you take a look.. there is a white SPACE before the " .. and that is wrong.
if should be:
export JAVA_HOME="/usr/lib/jvm/java-6-sun"
Or without " "
export JAVA_HOME=/usr/lib/jvm/java-6-sun

so.. take a look where JAVA_HOME is setted in your system.. and see is there is a white space..

Back to Top
Post: Oct 21st 2007 at 5:43 PM

you are VERDAMMT right!

now your original script works well too :)

thanks soooooooooo much !

i wanna learn how to write such a software tooo, could you please tell me how can i start as a noob in both java and linux ? any suggestion will be thankful !

Back to Top
Post: Oct 21st 2007 at 10:44 PM

I am unable to get it to work either :( Could someone help me? I used the x_86 installer after being unable to get it start with the other methods. Here is my error:

daaaman64@Govinda:~/tuxguitar-0.9.1-update1$ ~/tuxguitar-0.9.1-update1/tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/daaaman64/tuxguitar-0.9.1-update1/lib/libswt-pi-gtk-3232.so: /home/daaaman64/tuxguitar-0.9.1-update1/lib/libswt-pi-gtk-3232.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1030)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.(OS.java:22)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.(Display.java:126)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)

Back to Top
Post: Oct 22nd 2007 at 12:55 PM

Do you have a 64 bit architecture ???
if yes, download the x86_64 version of tuxguitar

Back to Top