Tux Guitar

Problems

Subject No sound



Author Message
Asmegin
Post: May 12th 2007 at 5:21 PM

Hello everyone, I recently just found out about tux guitar and i must say that it looks really good. I recently installed it on linux suse10.2, And it seems that it installed it easily on the respitory. Every thing was looking good and opened some of my guitar pro files in there and it picked it up just fine. The only problem that i have with it is that i don't have any sound whenever i play the track. I tried to find some solution from the forums including the whole "soundbank" thing. I tried to load it up on there too but i still don't have any luck. I wonder if i'm doing it wrong or not. I would appreciate if someone can help me out on it.


Back to Top
 
Valdemir.fodra@terra.com.br
Post: May 14th 2007 at 2:18 PM

Hello! I don't have sound im my tuxguitar, somebody can
help myself?


Back to Top
 
Julian
Post: May 14th 2007 at 5:20 PM

Hi,
try launch tuxguitar under a terminal.. and tell me if you get any error message.

can you paste here the result of this command? :
lsmod | grep snd_seq


Back to Top
 
Abhimanyu
Post: May 15th 2007 at 5:55 AM

Very Interesting Software but when I open a GuitarPro file (.gp3, .gp4) - it shows the follwing error and nothing happens after that :

Unavailable Soundbank Error


Back to Top
 
el.whappo@jabber.freenet.de
Post: May 15th 2007 at 8:51 AM

i got the same problem as Asmegin. first of all there was the soundbank problem but i solved it by downloading the deluxe soundbank from sun. but after all i still have no sound when i want to play my ptb-files but i don't get an error message.

lsmod | grep snd_seq says:

thomas@thomas-desktop:~$ lsmod | grep snd_seq
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_rawmidi 25472 2 snd_seq_midi,snd_mpu401_uart
snd_seq 52592 7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 4 snd_rtctimer,snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 19 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

running tuxguitar out of a terminal says:

thomas@thomas-desktop:~$ tuxguitar
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:165)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at java.lang.Class.newInstance0(Class.java:355)
at java.lang.Class.newInstance(Class.java:308)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.loadSynthesizer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.init(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.PluginManager.initPLugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPluginManager(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)

running tuxguitar with "aoss /usr/bin/tuxguitar" also doesn't work.

i don't know what to do. i'm using ubuntu 7.04 with gnome 2.18.1 and kernel 2.6.20-15-generic.

thanks a lot, thomas.


Back to Top
 
Julian
Post: May 15th 2007 at 9:04 AM

Hi,

To "el.whappo@jabber.freenet.de":
your Java Virtual machine throws you a "MidiUnavailableException", but you have the "snd_seq" module already loaded..
it happend with some sound cards (i don't know why), that java sound api can't run if there is another sound app running on the OS.. ( also a messenger app, can use sounds..)
the only solution i know for that, is load "snd_seq" and run with "aoss".. but its not your case..
So, i suggest you use the tuxguitar-alsa plugin.. and try use timidity as software synthesizer...

To "Abhimanyu":
you need download and install a java soundbank.
http://java.sun.com/products/java-media/sound/soundbanks.html


Bye


Back to Top
 
el.whappo
Post: May 15th 2007 at 9:21 AM

ok, i rebooted my pc and before running any app i started tuxguitar with aoss /usr/bin/tuxguitar but it still doesn't have any sound. timidity is already installed.

and theres no other solution?

thomas


Back to Top
 
Julian
Post: May 15th 2007 at 9:34 AM

i say you about the "tuxguitar-alsa" plugin..
to load native alsa ports. ( timidity ).

you should install the plugin, and go to menu: "Plugins -> TuxGuitar-alsa plugin" to select a timidity port.


Back to Top
 
Asmegin
Post: May 18th 2007 at 9:03 PM

I tried to type tuxguitar on the terminal, but i got and error out of it
asmegin@asmegin-Suse:~/Desktop> tuxguitar
bash: tuxguitar: command not found


Back to Top
 
Julian
Post: May 18th 2007 at 9:11 PM

That is because "tuxguitar" file is not at linux PATH..

so you need add the complete path to launch it..
/where_is_installed/tuxguitar

or
cd /where_is_installed
./tuxguitar


Back to Top
 
jamm
Post: May 19th 2007 at 5:56 AM

ei..my tux guitar was installed in windows. Help because it has no sound. I can't relate with what you're talking with in Linus or Mac? I need help with windows.. thanks.


Back to Top
 
Asmegin
Post: May 20th 2007 at 4:23 PM

I don't where exactly to look for it.

But i did find the tuxguitar.sh
and this is what it says
asmegin-Suse:~ # TuxGuitar.sh

configure java-environment ...
configuring TuxGuitar ...
starting TuxGuitar application ...
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/TuxGuitar/share/plugins/TuxGuitar-alsa.jar:/usr/share/java/TuxGuitar/TuxGuitar.jar:/usr/share/java/TuxGuitar/lib/itext-1.4.5.jar:/usr/share/java/swt/swt-gtk-3.2.jar
main class used: org.herac.tuxguitar.gui.TuxGuitar
flags used: -Xms128m -Xmx128m
options used: -Djava.library.path=/usr/lib64/swt:/usr/lib64:/usr/lib/swt:/usr/lib
arguments used:


Back to Top
 
Julian
Post: May 20th 2007 at 5:18 PM

"TuxGuitar.sh" ??
what release version of tuxguitar do you have installed ?


Back to Top
 
Asmegin
Post: May 22nd 2007 at 1:17 AM

This where i got it

[IMG]http://img.photobucket.com/albums/v504/Asmegin_Slayer/Screenshot.png[/IMG]


Back to Top
 
Julian
Post: May 22nd 2007 at 10:32 AM

mmm, you are using a repository version.. i'm not sure how is it maked. so i don't know if it's a bug of "tuxguitar" or "package"

in previous post you paste here, the result of "TuxGuitar.sh"
that cmd also launch the app ??

>java virtual machine used: /usr/lib/jvm/jre/bin/java
please, paste here the result of:
/usr/lib/jvm/jre/bin/java -version


Back to Top
 
Julian
Post: May 22nd 2007 at 10:42 AM

Wait, i see something..

you have:
TuxGuitar-alsa at classpath..
so i think that package cames with alsa plugin as default..

do you have a "Plugins -> TuxGuitar Alsa" in your tuxguitar menu ???

if its true,

you can disable the plugin, to play sounds with java sound api. (with soundbanks)

Or you need connect a software synthesizer to your alsa system.. and then load it on tuxguitar..
for example, you can install "timidity", then, launch
"timidity -iA -Os"
and run tuxguitar agian..
go to "plugins -> tuxguitar alsa" and select a timidity port.


Back to Top
 
Asmegin
Post: May 22nd 2007 at 11:06 AM

I'll definitly try this out when i go home


Back to Top
 
Asmegin
Post: May 26th 2007 at 3:04 PM

Julian, thank you very much, I disabled the alsa plugin, and it works wonderfully now. Thank you very much


Back to Top
 
Bryan
Post: May 26th 2007 at 7:11 PM

none of the fixes in here have worked

my sound was working until about a half hour ago and then it just quit and started giving me the unavailiable soundbank error


Back to Top
 
teruel
Post: May 28th 2007 at 7:19 PM

reinstall the aplication whit out the plugin.

and found ok.


Back to Top
 
Rogério
Post: Jun 10th 2007 at 3:55 PM

I got the problen "soundbase unavaiable" when i try to play it on windows XP pro. what should i do?


Back to Top
 
Julian
Post: Jun 10th 2007 at 4:06 PM

you need install the java sounbank..
follow the install instructions here:
http://java.sun.com/products/java-media/sound/soundbanks.html


Back to Top
 
Kimon
Post: Jul 20th 2007 at 9:24 AM

I tried the alsa plugin with timidity installed and I got no sound, I removed the plugin and tried the sun soundbank from the jre and still no sound.

CENTURION:/usr/lib64/jvm/jre/lib/audio # lsmod|grep snd_seq
snd_seq_dummy 21124 0
snd_seq 82976 1 snd_seq_dummy
snd_seq_device 26516 2 snd_seq_dummy,snd_seq
snd_timer 44680 4 snd_rtctimer,snd_seq,snd_pcm
snd 89384 16 snd_rtctimer,snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer


CENTURION:/ # usr/bin/TuxGuitar.sh

configure java-environment ...
configuring TuxGuitar ...
starting TuxGuitar application ...
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/TuxGuitar/TuxGuitar.jar:/usr/share/java/TuxGuitar/lib/itext-1.4.5.jar:/usr/share/java/swt/swt-gtk-3.2.jar
main class used: org.herac.tuxguitar.gui.TuxGuitar
flags used: -Xms128m -Xmx128m
options used: -Djava.library.path=/usr/lib64/swt:/usr/lib64:/usr/lib/swt:/usr/lib
arguments used:
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:154)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


Back to Top
 
Julian
Post: Jul 20th 2007 at 11:51 AM

Hi Kimon,
>I tried the alsa plugin...
did you build it from sources ??
because your paths, i assume you have a 64 bit arch.
but there is not prebuilded tuxguitar-alsa for 64 bit
so i don't think the x86 prebuilded package works under 64.

about the JRE sound: "Audio Device Unavailable"
i was never found that info.. but sun java sims use OSS as output under linux.
and OSS, have some conflicts when try to run more than one sound apps at the same time.
Note that the other app, don't should be only a Music app..
for example, a Messenger is not a music app but it play sounds.

"alsa-oss" fix this problem on some PC. ( not on all )
running:
aoss tuxguitar

about your kernel loaded modules ( lsmod|grep snd_seq )
they sims to be right..
So tell me.. do another "midi" app works in your system ??


Back to Top
 
Kimon
Post: Jul 21st 2007 at 12:55 PM

Solfege works fine, no additional tweaking whatsoever.I think it is relying on timidity too. I don't run it together with TuxGuitar if that's what you mean.


Yes it is a 64bit suse 10.2 system and I installed TG using rpm from an online repository. I have indeed a messenger running in the background but I've tried without the messenger too (I think).

I'll try to compile from source if you think it will help. But I try to use precompiled stuff when I can. It makes it easier to keep track.


Back to Top
 
Kimon
Post: Jul 21st 2007 at 1:03 PM

this what I got using aoss. no error but no sound either


kimon@CENTURION:/> aoss /usr/bin/TuxGuitar.sh

configure java-environment ...
configuring TuxGuitar ...
starting TuxGuitar application ...
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/TuxGuitar/share/plugins/TuxGuitar-alsa.jar:/usr/share/java/TuxGuitar/TuxGuitar.jar:/usr/share/java/TuxGuitar/lib/itext-1.4.5.jar:/usr/share/java/swt/swt-gtk-3.2.jar
main class used: org.herac.tuxguitar.gui.TuxGuitar
flags used: -Xms128m -Xmx128m
options used: -Djava.library.path=/usr/lib64/swt:/usr/lib64:/usr/lib/swt:/usr/lib
arguments used:


Back to Top
 
Kimon
Post: Jul 21st 2007 at 1:28 PM

I must be an idiot but I d/l the src tar's and according to the instructions there must be a script that I gotta run to install it. That script file doesn't seem to exist at all. Same for the alsa plugin.

I also tried the binary 64 TG version with a sun soundbank and I got unavailable midi exceptions again. I even quit the messenger app...


Back to Top
 
ArtInvent
Post: Aug 13th 2007 at 6:45 PM

I struggled a bit with no sound. Running Ubuntu Feisty 7.04. Using Java 6 JRE. Installed the deb package and got the soundbank error. Checked and there was already a soundbank in the correct Java folder. Then I discovered you need the TuxGuitar ALSA plugin. So I download that. Restart TuxGuitar. No sound. Search through the forums. Something vague in another thread here about Timidity. Timidity was already installed, but it does not appear in the Tuxguitar Alsa Plugin dropdown at all. Hmm. Stumble onto THIS thread. Find out that you have to FIRST have to run the command
$ timidity -iA -Os
Then I start Tuxguitar and can go enable 'Timidity port 0' in the Plugins | Tuxguitar-alsa Plugin section.

Okay, sound finally works.

Maybe you see where I am going with this. This is a pretty mickey mouse way to install and run a program. Seems like the Alsa plugin is pretty much a dependency or ought to be treated as such. And having to run a pre-command, also less than ideal. Pretty much everyone on Ubuntu (and probably other distros) are going to have this issue. There is a page on the Tuxguitar Documentation pages on installation in Ubuntu, but it doesn't say anything about the plugin or timidity or anything, all it talks about is the general stuff about installing the main deb package.

If these problems can't be rectified, at least put on that Ubuntu documentation page the above additional requirements and instructions. And make sure that a link to that page is on the Ubuntu Downloads page, because most people are just going to download the first deb package and not even know they need the plugin and go 'wtf.' A lot of people are just going to cross their eyes and give up. Too bad, because this is shaping up to be a very nice program indeed.


Back to Top
 
Anonymous
Post: Aug 21st 2007 at 11:25 AM

$ lsmod | grep snd_seq
snd_seq_device 8716 1 snd_rawmidi
snd 55268 14 snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer

I couldn't get the sound too
after installing timidity and tuxguitar alsa plugin, I got an error when opening tuxguitar:

java.lang.UnsatisfiedLinkError: /usr/lib/jni/libMidiReceiverJNI.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/jni/libMidiReceiverJNI.so)

can anyone help?

using Ubuntu 6.06
gnome 2.14.3


Back to Top
 
Julien
Post: Aug 28th 2007 at 2:56 PM

Hello

Ihave just installed tux guitar and alsa plugin, and I have no sound.
Here my config

lsmod | grep snd_seq
julien@Ubuntu:~$ lsmod | grep snd_seq
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 3 snd_rtctimer,snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 12 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device


Back to Top
 
Julian
Post: Aug 28th 2007 at 3:04 PM

Hi,
did you select a valid midi port ?
see at: Menu "Plugins -> TuxGuitar Alsa Plugin"
note that "Midi Through Port-0" don't sound as default.

you need install a software synthesizer ( like timidity )
and select it on tuxguitar.


Back to Top
 
Julien
Post: Aug 28th 2007 at 3:33 PM

I have install Timidity

where in Tux guitar do I select It


Back to Top
 
Julian
Post: Aug 28th 2007 at 3:48 PM

you need run the timidity daemon:

timidity -iA -Os &

and then restart tuxguitar.
go to "Plugins -> TuxGuitar Alsa Plugin" at menu,
and select the timidity port 128:0


i asume you are under ubuntu. (cause your prompt on the previous post "julien@Ubuntu")
if you have timidity from repositories,
you can edit:
/etc/default/timidity

and uncoment this line:
TIM_ALSASEQ=true

then .. timidity will start as default when your OS boot.

and also you will can do:
/etc/init.d/timidity start
/etc/init.d/timidity stop
to run/stop daemon


Back to Top
 
Anonymous
Post: Aug 28th 2007 at 3:53 PM

You are so balèze!!!!

Thank for all


Back to Top
 
DeadHead
Post: Sep 6th 2007 at 12:56 AM

Try this:
Make sure you have the latest Java installed for your Distro

Locate the Soundbank.gm, file OpenSuse uses /usr/lib/jvm/java-1.5.0-sun-1.5.0_update12/jre/lib/audio/soundbank.gm
for example.

Click on Settings from the Menu Bar
Select Configure TuxGuitar
Choose Sound Icon
Click the "Use Custom Sound Bank"Radio Button
Click the Folder Icon and select the directory containing Soundbank.gm,

If you have the Alas Plug-in intsalled you may have to deselect the Use Alas Plug-in Option from the Plug-Ins on Menu Bar

Hope this helps


Back to Top
 
Lobo23
Post: Mar 13th 2008 at 6:33 AM

This totally solved my "No Sound" problem. When I open Tux Guitar it still says the "Java Sound API cannot blah, blah", but I installed timidity, opened tux guitar, went to tools, went to settings, went to sound, switched midi ports, used the timidity -iA -Os command, restarted tuxguitar, then I learned "Heart Shaped Box" on guitar.

Thank you all so much.


Back to Top
 
samyazza
Post: Oct 26th 2008 at 11:24 PM

What can I do if I don't have a plugins menu in my tuxguitar??


Back to Top
 
Anonymous
Post: Oct 27th 2008 at 2:53 AM

Damn.
I could get the sound when using the Java Sound Synthesizer port, but it sounds pretty cheesy.
I've installed the java deluxe soundbank and configured that as the main soundbank in the plugin menu.
The sequencer doesn't seem to matter.

I need help, because I wanna get rid of this horrible sound.


Back to Top
 
Julian
Post: Nov 1st 2008 at 12:19 PM

samyazza,
This topic is so old. maybe you have a different version of tuxguitar.
If you have TuxGuitar-1.0, plugins menu is at "Tools -> Plugins"
If you have tuxguitar-0.9.1, plugins is at the top menu.
but it's only visible "if you have any plugin installed"

Anonymous,
What Operating system are you using ?


Back to Top
 
Matt Milholen
Post: May 29th 2009 at 5:57 AM

installing timidity from terminal and running Alsa, choose the timidity port0 from settings and this worked for me! I have sound.


Back to Top
 
JawnDee
Post: Jun 2nd 2009 at 9:34 PM

Okay, I'm new to Debian (and linux in general) so i'm not well versed in Terminal, to say that I have no clue what I'm doing when I use it, would be extremely correct.

What do I have to do to make my Tuxguitar have sound?


Back to Top
 
JawnDee
Post: Jun 2nd 2009 at 9:43 PM

and yes, i checked that MIDI works on my computer, it does, I can play a midi file fine in my audio player. Why doesn't my Tuxguitar have sound?


Back to Top
 
Julian
Post: Jun 5th 2009 at 11:17 PM

JawnDee,

The first question is do you have "tuxguitar-alsa" installed ???
( if you downloaded tuxguitar from here, you should have it.. but if you got tuxguitar from debian reporisoties, it's on a different package "tuxguitar-alsa" .. so make sure you have it installed ).

the second.. if your audio player play sounds.. you should have any MIDI synth ( maybe timidity, or fluidsynth ) installed..

exec on a terminal "aconnect -o"
do you see timidity ???

if yes, just go from tuxguitar settings ( Tools -> Settings )
and on Sound section, make sure you have the first timidity port selected on MIDI Port


Back to Top
 
Craig
Post: Jun 16th 2009 at 7:40 PM

I have just installed Ubuntu on my system. One of the first things i wanted to use was tux guitar but now i have no sound on it. i am completely new to Ubuntu so step by step instructions would be much appreciated.

Thank You!


Back to Top
 
Dagger.52@hotmail.com
Post: Jun 18th 2009 at 8:15 PM

I have no sound on my tuxguitar eigther. I use the latest Ubuntu, and I've tried downloading Java stuff but no matter what I download nothing works. I have no clue what to do right now.


Back to Top
 
Dagger.52@hotmail.com
Post: Jun 18th 2009 at 8:22 PM

It might be good to let you know that I'm also completely new to Ubuntu so I'll pry need step by step instructions. Help is much apreciated.


Back to Top
 
Maia
Post: Jun 24th 2009 at 2:46 AM

I had no sound on may Tuxguitar with Ubuntu 9.04. I solved the problem using the java's soundbank and unmark all the other (alsa, oss, ...) output plugins.


Back to Top
 
Similar problem, found a solution
Post: Jun 24th 2009 at 5:07 AM

I downloaded Tuxguitar 1.1 for Windows a few hours ago. after writing a song i exported it as a MIDI file and then it would no longer play in the Tux program. This worked for me...

At the top menu bar where it says File|Edit|View| etc..., go to TOOLS -> SETTINGS -> SOUND -> MIDI PORT

and pick Java Sound Sythesizer. Mine was set to Microsoft Midi Mapper by default.

I've Switched back and forth and made midi files repeatedly now and the problem has not resurfaced, however under the Microsoft Midi Mapper setting it remains Silent, but that doesn't matter to me because the sounds back as long as you use the Java Sound Synth MIDI PORT.


P.S.
I got no error messages of any kind, just no sound, and i'm using TuxGuitar-1.1 i have no idea if this works for other versions or if this was already discussed. Hope this works for you.


Back to Top
 
Anonymous
Post: Aug 1st 2009 at 12:46 AM

The person above me is winrar.


Back to Top
 
Costas
Post: Aug 2nd 2009 at 5:11 PM

This article helped me get timidity run with tuxguitar

https://help.ubuntu.com/community/Midi/SoftwareSynthesisHowTo?action=show&redirect=MidiSoftwareSynthesisHowTo


Back to Top
 
Marc
Post: Aug 15th 2009 at 6:34 PM

ubuntu 9.04
tuxguitar 1.0
tuxguitar-alsa
tuxguitar-oss
timidity 2.13.2-20ubuntu3 (jaunty)
tools>settings>sound>MIDI Sequencer>Tux Guitar Sequencer
tools>settings>sound>MIDI Port>TiMidity port 0 #1

Everything works *except* sound. I can export a tab to MIDI, and play the MIDI outside tuxguitar, but not inside. When run from term, I get this:

marc@tulip:~$ tuxguitar
marc@tulip:~$

No erros, nothin'. HELP!


Back to Top
 
Julian
Post: Aug 17th 2009 at 8:09 PM

Try don't have alsa, and oss plugins installed together..
uninstall one ( i recommend you keep alsa )

if you are running pulseaudio, it could be cause problems to timidity..
try start timidity from a terminal:
timidity -iA -Os

and, without close this terminal, select the new timidity port ( usually 129:0 )


Back to Top
 
Marc
Post: Aug 18th 2009 at 12:00 AM

Yo, Julian! Thanks!


Back to Top
 
Jade
Post: Aug 30th 2009 at 10:45 AM

The solution was that the timidity was missing

sudo apt-get install timidity

and then

timidity -iA -Os

Then everything works

Thanks for everybody


Back to Top
 
In Dire need.
Post: Feb 20th 2010 at 5:59 PM

I am thinking it has smth do with ERROR:" An error occurred when trying to init plugin".i dled tuxguitar 1.2 but could not open from the shortcut,stating JNI Exception Reason:not enough memory,but found a way to open by ms-dos file.However still no sound.help?In tuxguitar 1.2 there isnt,ERROR"An error occurred when trying to init plugin".help pls!


Back to Top
 
In Dire Need
Post: Feb 21st 2010 at 12:24 PM

Found solution


Back to Top