Tux Guitar


Subject Can't use numbers on the keyboard !

Author Message
Post: Sep 12th 2011 at 10:52 AM

Hello :-)
I have a big problem ..
When i want to write Tabs i can't use "1 2 3 4 5 6 7 8 9 0"
Tux guitar does not recognize this numbers.
I'm on Mac OSX 10.6
Anyone have a solution ? :-)
Thanks !

Back to Top
Post: Sep 16th 2011 at 2:54 AM

Hi Lou,

I also use Mac OSX 10.6 and I have never encountered problems entering numbers in tab.

Are you sure that you haven't activated numlock (F6) on your keyboard?

Are you able to use numbers on other applications on your Mac?

Have you used Tuxguitar on Windows and Linux? If so, did you encounter the same problem?

Have you tried Tuxguitar on another Mac? If so did you encounter the same problem?

Have you tried reinstalling Tuxguitar (on the off chance that something went wrong with the original installation)?

If the reinstallation of Tuxguitar doesn't work try repairing your disk permissions via the Mac OS X Disk Utility? (This is fairly straightforward but if you are not sure how to do this then do an internet search and you will find reliable guidance.)

If the problem persists post back with more information about what you are trying to do and the problem you are encountering.

Kind regards,


Back to Top
Post: Sep 25th 2011 at 3:25 AM

I have exactly the same problem. I have a recent macbook pro with french keyboard: it does have a keypad for numbers, the only way to type numbers is using "shift" or "caps lock". I guess the problem is specific to such laptops.

Back to Top
Post: Sep 25th 2011 at 3:26 AM

sorry, I meant "it does *not* have a keypad..."

Back to Top
Post: Sep 25th 2011 at 3:37 AM

The only way I found to enter a number without using a number key is: use the key "l" (to tie notes) twice, which makes a 0 appear. Then use shift+right/left to increase/decrease the number.

To write 14 on the 4th string: write a 0 on the first string (type l twice), and then use shift+down 3 times.

Writing 21 on the first string takes much more time...

Back to Top
Post: Sep 25th 2011 at 10:51 AM

Hi Mathieu,

I have a 2006 MacBook Pro with a UK keyboard running OS X 10.6.8. My MacBook also does not have a numbers keypad. However, I do not experience the problem that you describe. i.e. I am able to enter tab into TuxGuitar by pressing the number keys without using "shift" or "caps lock"'.

I wonder whether there is a problem with the configuration of your system in that you have a French keyboard but the OS and TuxGuitar might be set up for UK or USA?

Anyway, it seems to me that there 5 possibilities:

1. A highly specific bug/quirk related to your particular set-up; sorry, I can't help you with this. More information would be needed.

2. That the issue might be because you have a french keyboard but that the OS might be misconfigured for another country (e.g. UK or USA); this is set up when you start your OS for the first time. It should be possible to change this via system preferences; my guess is that you change the keyboard setup via /System Preferences/Language & Text/Input Sources. Btw: I would also guess that it you are getting the OS menu items in English (rather that French) that might indicate a misconfiguration.

3. That there is a problem with your OS; try repairing your disk permissions (/Applications/Utilities/Disk Utility/First Aid/Repair Disk Permissions).

4. That there might be an issue with your configuration of TuxGuitar (that is somehow conflicting with you OS configuration) again related to language (/Tools/Setting/Language).

5. That there is something wrong with your installation of TuxGuitar; try reinstalling TuxGuitar.

If the problem persists then post back giving more details of your system and what the outcome of any steps to try and rectify the problem.

Also, post back if you solve the problem.

Kind regards,


Back to Top
Post: Sep 30th 2011 at 9:38 AM


I have the same problem with my MacBook Pro and I think there is only 2 solutions, cause the installation is correctly done :

- Use "l" twice then use shift+right or left to increase/decrease the number
- Buy a keypad, it will normally work (it isn't too expensive)

Kind regards,


Back to Top
Post: Oct 2nd 2011 at 12:07 AM


I presume that you have an AZERTY keyboard? The normal layout for this keyboard is to put the numbers on upper shift (whereas QWERTY keyboards have numbers on lower shift).

This is not a fault or bug. It's definitely not a problem with Tuxguitar. It's probably not fair to describe it as a "problem" at all; it is just the normal behaviour of an AZERTY keyboard.

If you didn't intend to get an AZERTY keyboard (and the purchase was fairly recent) then ask Apple if they will change to a QWERTY keyboard. Keyboard mix ups are not uncommon and Apple and generally sympathetic.

Kind regards,


Back to Top
Post: Dec 5th 2011 at 5:43 PM

I have a macbook with qwerty keyboard.. And it doesn't work for me either.
I think it is something with the new MacBooks..

Back to Top
Post: Dec 19th 2011 at 12:25 AM

Hi ronnyt,

The keyboard layout that your computer users is the one you selected in the Setup Assistant the first time you started Mac OS X. You cab change this as follows:

1. Go to System Preferences.

2. Select Accounts and unlock it.

3. Click Login Options.

4. Select the "Show Input menu in login window" checkbox.

5. From the Apple menu, choose Log Out.

6. At the login window, click the name or flag icon of the currently selected keyboard layout (it appears below the name of the computer), then select the desired keyboard layout.

Kind regards,


Back to Top
Post: Dec 30th 2011 at 8:48 PM

Hi Guys,

I'm on windows 7 but I've got the same problem.

When in standard AZERTY (french) mode, I can't enter the number on the tab neither by using the CAPS LOCK nor by using the SHIFT button.

However, I found out that if you change your keyboard to English (US) in your regional settings : It works !!!

That, of course, is only a work around until a more definitive solution is found. I can't make up if it's a TuxGuitar issue (not recognizing the keyboard entries) or an OS system though.

You Apple guys might want to give that a try in case it works for you.

By the way, awesome job with this tool !! thanks a lot for that.

Take care,

Back to Top
Post: Jan 3rd 2012 at 4:05 PM


I have the same problem with Windows 7, and used to have it with XP. The problem is related to the use of an AZERTY keyboard, as mentionned above.

Modifying the system settings to turn it to a QWERTY keyboard wouldn't be a solution, because I would have problems when typing words (filenames, lyrics...) and using special characters. The AZERTY display is used in several countries, mainly french-speaking.

So here is an issue for the developpers of TuxGuitar ! I guess it's probably not to hard to solve, probably just need that someone take the time to give it a look !

Anyway, TuxGuitar is really a good software, so I hope you will be able to solve this !

Back to Top