Tux Guitar


Subject Tuxguitar wont start on MAC

Author Message
Post: Jul 28th 2010 at 1:08 PM

i have the snow leopard software on my MAC
tuc guitar ill download fine... but then when i select the icon to open it, the computer asks me if i want to open the downloaded file i select yes, and it does nothing, i have tried downloading the software again same thing happens

Back to Top
Post: Jul 30th 2010 at 7:04 PM

Try downloading the 64 bit version of tuxguitar for mac.

Back to Top
allman brothers rock
Post: Sep 9th 2010 at 11:20 PM

i tried that with out success

Back to Top
Post: Sep 11th 2010 at 10:03 AM

Same problem here! =( Icon jumps one-two times and then disappers.

Back to Top
Post: Sep 11th 2010 at 10:19 PM

You would need to launch TuxGuitar from terminal and post what problem you encountered

Generally, make sure to download the right version (32 bits vs 64 bits)

Back to Top
Post: Sep 12th 2010 at 3:23 PM

I tried installing the 32 then the 64 bit version (I'm sure it is a 64bit architecture), but the .app won't launch. I can't launch the application from the terminal (looks like it can't find it). It's pretty unnerving, and not the first free application that I have this problem with. (Moving from Ubuntu to Snow Leopard lately.)

grandveymont:~ mathilde$ ioreg -l -p IODeviceTree | grep firmware-abi
| | "firmware-abi" = <"EFI64">

Back to Top
Post: Sep 12th 2010 at 10:09 PM

Mathoche: you will need to specify an absolute path to the executable since it's most probably not on your PATH.

You can simply right-click on Tuxguitar.app, select "Show Package Contents", navigate to Contents/MacOS and then double-click the "tuxguitar" executable there.

Back to Top
Post: Sep 19th 2010 at 7:34 AM

I can't find the 64 bit version.
If I click on the link at the download page, it opens always a 32 bit version. I try it but don't open in snow leopard. Please, where I can find the snow leopard version??
Thank you!

Back to Top
Post: Sep 19th 2010 at 12:04 PM

Thanks Auria, but it still doesn't launch: I got an error message from the console, from both 32 and 64 bit versions.
Java is updated to 1.6.20, and I'm rather stuck here.

grandveymont:~ mathilde$ Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.(Unknown Source)
at org.eclipse.swt.internal.cocoa.NSThread.isMainThread(Unknown Source)
at org.eclipse.swt.graphics.Device.(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

grandveymont:~ mathilde$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)

Back to Top
Post: Sep 19th 2010 at 6:29 PM

I found the right version and it works!

Back to Top
Post: Sep 20th 2010 at 6:58 PM

Works fine now with http://sourceforge.net/projects/tuxguitar/files/TuxGuitar/TuxGuitar-1.2/tuxguitar-1.2-macosx10.5-cocoa-64.dmg/download

Back to Top
Post: Sep 26th 2010 at 1:24 AM

I'm running Snow Leopard (10.6.4) and TuxGuitar recently stopped working when I changed a Java preference to fix a web browser issue.

Here's my solution: go to Java Preferences.app in the utilities folder and if using the 64 bit version of TG, make sure the 64 bit version of Java is set to run first, or make sure the 32 bit version of Java is set to run first if using 32 bit version of TG. Just drag back and forth in the Java Preferences window.

Hope this helps someone else!

Back to Top
Post: Jan 4th 2011 at 10:25 PM

I experienced the same problem as above, The software would not start on my mac
I uninstalled the software and used the link to download it again.
The link works fine and the software worked first time and works fine, iv had no problems with it.

Back to Top