Tux Guitar


Subject Tuxguitar doesn't work when playing music

Author Message
Post: Feb 18th 2010 at 10:29 AM

I can't play tuxguitar while another sound application is running, like Movie player or rhythmbox for example. It just says "MIDI System is unavailable".
It runs fine if there are no other applications running that use sound, but when I'm already running tuxguitar and try playing a song in rhythmbox for example, it just won't play.

I've had a search on google and can't find anything that works. I've tried both versions 1.1 and 1.2, and I'm using Ubuntu 9.10. Please help!

Back to Top
Post: Feb 18th 2010 at 4:08 PM

This may be because your MIDI Out is not using Pulse Audio as output driver. Try use a different than the java sound synthesizer.

Back to Top
Post: Feb 20th 2010 at 1:44 PM

How do I do that? In the sound settings, all I can see are the TuxGuitar Sequencer and Realtime Sequencer under the MIDI sequencer choices, and Java Sound Synthesizer is the only option in the choices of MIDI port.

Back to Top
Post: Feb 20th 2010 at 1:54 PM

Actually nevermind, I fixed it by downloading all the other plugins, running timidity in the background with 'timidity -iA -Os' and then selecting 'Timidity port 0 [129:0]' in the sound settings. Thanks anyway!

Back to Top