Tux Guitar


Subject Tuxguitar won't open (Mac)

Author Message
Post: Jan 12th 2010 at 8:15 PM

Hi, I'm running Mac OS X 10.6.2, I downloaded Tuxguitar version 1.2 today and it won't open. This is frustrating as version 1.1 worked (though i remember having a problem when i first downloaded that which I sorted but I can't remember how, something to do with changing the it to 32 or 64 bit i think). I tried having the 'Force Quit Applications' window up which shows you what applications are open and it flashes up there for a second and then disappears. Any help much appreciated, cheers.

Back to Top
Post: Jan 13th 2010 at 6:03 PM

I downloaded the 32 bit version, which works, so problem sorted.

Back to Top
Post: Jan 14th 2010 at 7:08 PM

Mine wont open now either, it 'quits unexpectedly' and offers me to ignore, relaunch or report...
im running leopard, and it worked until yesterday :/

Back to Top
Post: Jan 15th 2010 at 8:04 PM

Neither version will run on my Mac running 10.6.2

Back to Top
Post: Jan 16th 2010 at 11:40 AM

this works on my snow leopard


Back to Top
Post: May 7th 2010 at 6:13 PM

still won't work for me =/ I am having the same problem as well

Back to Top
Post: May 10th 2010 at 10:29 PM

Yeah, I'm running Mac os 10.6.3 and it won't open for me either, so frustrating. Why is this so?

Back to Top
Post: May 22nd 2010 at 1:17 PM

Same problem. It appears it's 10.6.3 which cause problem. Have you resolve it ?

Back to Top
Post: May 22nd 2010 at 6:30 PM

Same problem. Running 10.6.3. Have tried all 3 versions with both 32 and 64 bit Java but crashes after displaying splash screen. Here's the top section of the problem report in case this helps someone debug:

Process: java [13649]
Path: /Volumes/TuxGuitar 1.2 Cocoa 64-bits Edition/Tuxguitar.app/Contents/MacOS/tuxguitar
Identifier: org.herac.tuxguitar
Version: 1.2 (1.2)
Code Type: X86-64 (Native)
Parent Process: launchd [4460]

Date/Time: 2010-05-22 11:25:42.906 -0700
OS Version: Mac OS X 10.6.3 (10D578)
Report Version: 6
Sleep/Wake UUID: 3A0E6C58-09FD-4D2B-BAE0-6F2CEDFFA823

Interval Since Last Report: 314775 sec
Crashes Since Last Report: 11
Per-App Interval Since Last Report: 33 sec
Per-App Crashes Since Last Report: 9
Anonymous UUID: 1AC2A41C-C894-473B-B5AF-9C413CCD72BD

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Application Specific Information:

Java information:
Exception type: Bus Error (0xa) at pc=0x00007fff87e4a4b0

Java VM: Java HotSpot(TM) 64-Bit Server VM (14.3-b01-101 mixed mode macosx-amd64)

Current thread (0x0000000102883000): JavaThread "Thread-0" daemon [_thread_in_native, id=1891503072, stack(0x00007fff5f400000,0x00007fff5fc00000)]
Stack: [0x00007fff5f400000,0x00007fff5fc00000]
Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j com.sun.media.sound.MidiInDeviceProvider.nGetName(I)Ljava/lang/String;+0
j com.sun.media.sound.MidiInDeviceProvider.access$100(I)Ljava/lang/String;+1
j com.sun.media.sound.MidiInDeviceProvider$MidiInDeviceInfo.(ILjava/lang/Class;)V+2
j com.sun.media.sound.MidiInDeviceProvider$MidiInDeviceInfo.(ILjava/lang/Class;Lcom/sun/media/sound/MidiInDeviceProvider$1;)V+3
j com.sun.media.sound.MidiInDeviceProvider.createInfo(I)Lcom/sun/media/sound/AbstractMidiDeviceProvider$Info;+17
j com.sun.media.sound.AbstractMidiDeviceProvider.readDeviceInfos()V+101
j com.sun.media.sound.AbstractMidiDeviceProvider.getDeviceInfo()[Ljavax/sound/midi/MidiDevice$Info;+1
j javax.sound.midi.MidiSystem.getMidiDeviceInfo()[Ljavax/sound/midi/MidiDevice$Info;+36
j org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts()Ljava/util/List;+8
j org.herac.tuxguitar.player.base.MidiPlayer.addOutputPortProvider(Lorg/herac/tuxguitar/player/base/MidiOutputPortProvider;Z)V+13
j org.herac.tuxguitar.gui.system.plugins.base.TGMidiOutputPortProviderPlugin.addPlugin()V+23
j org.herac.tuxguitar.gui.system.plugins.base.TGMidiOutputPortProviderPlugin.setEnabled(Z)V+5
j org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Z)V+26
j org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins()V+35
j org.herac.tuxguitar.gui.TuxGuitar.displayGUI([Ljava/lang/String;)V+101
j org.herac.tuxguitar.gui.TGMain.main([Ljava/lang/String;)V+4
v ~StubRoutines::call_stub

Back to Top
Post: May 23rd 2010 at 7:23 AM

It's a good thing to found this error.
I'm newbie in Mac OS. Where did you find his error ? What's this file which content this ?
I tried both dmg for 32 and 64 bit, but it's not working for me too.

One solution I found is to run tuxguitar in command line.
For example :

But I don't understand what it's not working with double click...

Another solution is to run Tuxguitar with Java webStart (it's working for me too...)

Back to Top
Post: May 27th 2010 at 4:00 AM

You can find the error information by opening a console window and displaying console messages. There will be a line with Date-Time-ReportCrash[ID] Saved crash report for XXX to path.crash. Just navigate to path.crash to get the report.

Opening from a terminal window (command line) isn't working for me.

Back to Top
Post: May 27th 2010 at 8:52 PM

Did you try to execute java web start ?
I don't know if it works for me because I run java web start before...

Back to Top
Post: Jun 1st 2010 at 11:45 PM

Dave, because your error log, i seems that the error is caused by the Java Sound Api plugin..
you you try removing (or just move to a back folder) the file named "tuxguitar-jsa.jar" at share/plugins folder ?

Back to Top
Post: Jun 9th 2010 at 4:50 AM


Wow, I don't know how you figured that out from the log I posted but removing that file worked. Thanks so much.

If anyone else is having this problem - you find the file by right clicking on Tuxguitar and selecting "Show Package Contents" then drill down and remove the file.

Back to Top
Post: Jul 30th 2010 at 10:57 PM

Thanks !!!
It works !

Back to Top
Post: Sep 14th 2010 at 3:16 AM

I tried deleting the tuxguitar-jsa.jar file but it wont let me because it says it cant be deleted. Any suggestions?

Back to Top
Post: Sep 26th 2010 at 1:26 AM

I'm running Snow Leopard (10.6.4) and TuxGuitar recently stopped working when I changed a Java preference to fix a web browser issue.

Here's my solution: go to Java Preferences.app in the utilities folder and if using the 64 bit version of TG, make sure the 64 bit version of Java is set to run first, or make sure the 32 bit version of Java is set to run first if using 32 bit version of TG. Just drag back and forth in the Java Preferences window.

Hope this helps someone else!

Back to Top
Post: Oct 23rd 2010 at 10:33 PM

Nathan! your solition works like a charm (Macbook Pro C2D.8hgz Snow Leopard 10.6.4)


Back to Top
Post: Nov 15th 2010 at 4:15 PM

I'm running 64-bit Tuxguitar under Mac OS X 10.6.5
I didn't have to delete the tuxguitar-jsa.jar file and opposing to Nathan I had to set the preference to run 32-bit BEFORE the 64-bit.
I goth this idea from this error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM

This isn't the full terminal log but the only interesting line.
anyway it works now but I'd rather have the 64-bit javascripts run first so this is not ideal
If I have to change this every time I use Tuxguitar or have to keep the Java preferences as such.

still it's a working free tab viewer/editor for a mac

Back to Top
Post: Nov 18th 2010 at 5:37 PM

ok, i download it, but then it begins to open, the jumping icon, then just closes... i dont get a notice for closing unexpectedly cause it never really opened?

what can i do

Back to Top
Post: Nov 27th 2010 at 12:29 PM

I have exactly the same issue, running OSX 10.6.5 2.4GHz Macbook pro - tried the command line, tried downloading both the one (Recommended package for Mac OS X 10.5 (Leopard) and Snow leopard.

how can this be fixed?

Back to Top
Post: Nov 28th 2010 at 5:30 PM

nathan i luv ye !!!! (macbook pro 7.1 snowleo 10.6.5)

Back to Top
Post: Nov 28th 2010 at 5:33 PM

just fo the record: 64 bit version won't works anyway, 32 bit version works if u put java32 before java64 in Java Preferences.app in the utilities folder. thanx dude!

Back to Top
Post: Dec 23rd 2010 at 2:52 AM

Thanks Nathan!

To sum it up.

1. Download 32bit version.
2. Open up Utilities
3. Open Java Preferences
4. In the General tab, make sure Java 32bit is placed above Java 64bit
5. Open TuxGuitar and enjoy!

Back to Top
Post: Feb 10th 2012 at 12:04 AM

@Nathan: Thanks Buddy ..... U r a magician .. cheers m/

Back to Top