Tux Guitar


Subject Configure + info not working in -- Tools / Plugins

Author Message
Post: Dec 20th 2009 at 2:09 AM

When I select Tools / Plugins, neither the configure or info button is working. When I press either it freezes for a few seconds and then quits. Since I can't configure fluidsynth, it does not show up in Settings / Sound as a midi port. The configure or info button doesn't work for any of the plugins.

I'm running it on 64 bit Arch Linux with OSS as my sound system. I've installed a sound font, fluidsynth and Timidity++ and had it working until recently. I've also tried both openjdk6 and jre to no avail.

Is there any way to manually select fluidsynth as the default plugin.


Back to Top
Post: Dec 24th 2009 at 4:42 PM

See this topic:

I'm sure you are having same problem.

Back to Top
Post: Dec 25th 2009 at 12:49 AM

Thanks Julian

Although I try to do my homework before posting I apparently missed your reply to a fellow ARCHer:


Downloading swt-3.6 and replacing the swt.jar file worked perfectly on my 32 bit OS. There is no 64 bit version of 3.6 yet and so it has to be compiled by the user. I'll look into this again, but I'm more familar with "C" programs than java and eclipse.

The link you provided above was exactly the problem I was having. I'll take another look at it when I'm less tired, but I'm not quite as motivated now since I can use tuxguitar on my 32 bit Arch OS.

Your help is truely apprciated.

Thanks Again !

Back to Top
Post: Dec 25th 2009 at 2:33 PM

>> There is no 64 bit version of 3.6 yet

Yes it is... at www.eclipse.org/swt, you have to click on "More" link, that will redirect you to a page with all available packages..

So you'll able to download this package:

Otherwise, you could download the latest tuxguitar version from this page.. that already includes SWT 3.6

Back to Top
Post: Dec 26th 2009 at 1:25 PM

>> There is no 64 bit version of 3.6 yet

>> Yes it is... at www.eclipse.org/swt, you have to ...

It worked like a charm, tuxguitar is working on both my OS's.

I think I misunderstood the FAQ on the need to compile for the 64 bit version. That must have been for the swt-GTK and not just the swt.jar file. I should have continued looking anyway.

Thanks Again for your help.

Back to Top