Tux Guitar


Subject No more colored squares behind instruments

Author Message
Post: Oct 20th 2009 at 9:37 AM

I use Tuxguitar on 2 Arch Linux machines for quite some time now and am very pleased with it. A couple of days ago I updated my 2 systems via pacman -Syu, it was only 2 weeks ago. Since then, I can't see the colored squares behind the instrument names anymore. They indicate when the instruments play, but all I see is a big empty grey area. Playback is still fine though. Happens on both machines.

Anyone else experiencing this issue? As far as I can tell, some of the most important updates between the time it was working and stopped working are the new kernel and Gnome 2.28. I tried reinstalling tuxguitar, openjdk and also tried with other GTK themes, but all to no avail.

Also another problem that I have since then is that when I clock on tools - plugins - java sound api - configure --> I don't get the window to select a soundbank anymore. Just nothing happens.

Setup box 1:
Pentium 4
1,5 GB RAM
Nvidia FX5900XT
XFCE 4.6.1

Setup laptop2:
HP 6730b
Intel Centrino Duo 2
Intel GMA 4500
Gnome 2.28

I use OpenJDK as JRE, Java API for sound playback and Gervill as midi port.

Back to Top
Post: Oct 20th 2009 at 2:20 PM


Yes, i saw this problem 2 days ago after update my debian testing. this is a SWT issue with this GTK or Cairo version (not exactly sure what of both), they fixed the problem on latest SWT development version, 3.6M2

So you have to download swt 3.6

Uncompress it, and replace the swt.jar that tuxguitar uses to this newone.

Back to Top
Post: Oct 20th 2009 at 3:00 PM

Thanks Julian! Always to the rescue :-)

Will the stable version (3.5.1) do too or does it has to be 3.6m2?

Back to Top
Post: Oct 20th 2009 at 3:08 PM

Just tried it out, only 3.6m2 works, thanks for helping me out. It also solves the soundbank problem ;-)

Back to Top
Post: Oct 20th 2009 at 3:15 PM

yes, it also happens with 3.5.1, i tested it yesteday.
i didn't tested 3.6M1, only M2 where the bug is fixed.
looking the sources, the bug is fixed at the GC class..
( if i copy the GC.class of 3.6 in 3.5, the bug is fixed )

I also was testing, override only this file..
i mean, if i add this GC.class of 3.6, with the tuxguitar.jar classes, then it works with swt 3.4 or 3.5 (didn't test with 3.3 ).. because the java classloader, find first the GC in tuxguitar.jar than in swt.jar

Back to Top
Post: Oct 21st 2009 at 8:32 AM

I posted this on the Arch forums too and told the users who have the same problem how to solve it.

Thank you Julian for another fine intervention :-)
You really are the best!

Back to Top
Post: Jan 22nd 2010 at 7:55 PM

got the same in KDE4 on Ubuntu karmic (9.10). Maybe the packet managers are behind? the system is up to date (at least it thinks it is) and I found libswt-cairo-gtk-3.4-jni (guess that's what causes the problem??) installed. Is there anything I can do except wait?

Back to Top
Post: Jan 23rd 2010 at 1:23 PM

gepomuk, our packages already include SWT 3.6 that solve these problems.. did you tried downloading one of them ?

Back to Top