Tux Guitar


Subject No lines for notes and tabs

Author Message
Post: Aug 24th 2009 at 8:58 PM


TuxGuitar works but there is a problem with the Horizontals lines (for the notes and tabs). They are not Visible.

Has anyone an idea how solve this Problem???

Thank you and sorry for my english!


Back to Top
Post: Aug 24th 2009 at 11:49 PM

GOSH me too, its freakin confusing

Back to Top
Post: Aug 25th 2009 at 12:14 PM

It's supposed that they are gray..
try go to Tools -> Settings, and set them to black.

Back to Top
Post: Nov 4th 2009 at 10:17 PM

changing the color to black, still same problem

Back to Top
Post: Nov 5th 2009 at 6:21 AM

You can believe that's a bug. Same problem running with Ubuntu 9.10

Back to Top
Post: Nov 5th 2009 at 1:10 PM

Is this problem happening with tuxguitar 1.2, with packages provided by this site ?

Or more easy to test.. does it happens with this JNLP ?

Back to Top
Post: Nov 5th 2009 at 5:15 PM

I've got the same, vesion 1.2 on ubuntu 9.10,package just downloaded from http://tuxguitar.herac.com.ar/

Back to Top
Post: Nov 5th 2009 at 5:25 PM

Could you provide any screenshot link ??

and paste here the result of this command please:
cat ~/.tuxguitar-1.2/config.properties

Back to Top
Post: Nov 5th 2009 at 5:57 PM

cat .tuxguitar-1.2/config.properties
#System Configuration
#Thu Nov 05 18:08:32 CET 2009

Free Image Hosting at www.ImageShack.us

Back to Top
Post: Nov 5th 2009 at 6:36 PM

That's all that you see on your configuration file ??

Anyway.. do you have any special composite ( like compiz ) ?

What architecture is your PC ?

also please, paste me the log of: tuxguitar -i

Back to Top
Post: Nov 5th 2009 at 8:41 PM

-> OS-Name: Linux
-> OS-Arch: i386
Hi, here's my log. The package I've downloaded is not an Ubuntu package but only the GNU/Linux-x86 Installer :

-> JVM-Name: Java HotSpot(TM) Client VM
-> JVM-Version: 14.2-b01
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_16
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-6-sun-
-> Java-Class-Path: :/usr/share/tuxguitar/:/usr/share/tuxguitar//tuxguitar.jar:/usr/share/java/itext.jar:/usr/share/java/swt.jar:
-> Java-Library-Path: /usr/lib/jni

and a screenshot with fretboard


Back to Top
Post: Nov 5th 2009 at 9:04 PM

There is something that i don't understand.
if you downloaded 1.2 package from this site ( see the installer, or the .deb package.. it don't matters )

So why do you have these paths ?

I'm very interested on this one: /usr/share/java/swt.jar

If you downloaded the GNU/Linux-x86 installer..
so SWT must be at:

If you get the .deb, it have to be at:

Can it be that you have both, 1.1 and 1.2 versions installed ??

If yes, note that the installer don't adds binary files at /usr/bin.
so, there is no "tuxguitar" at path.
you have to exec:

Or make 2 clicks to the file.

So if you had 1.1 installed, and you did "tuxguitar -i", i'm sure you executed tuxguitar 1.1.

could it be what happened ?

I'm really insterested on SWT version, because there is a bug with swt lesser than 3.6 and GTK versions 2.18+, and this is why in the new version i redistributed swt 3.6 (since it's not at allmost distribution repositories )

but /usr/share/java/swt.jar seems to be the ubuntu's repository SWT, that is lesser than 3.6.

Back to Top
Post: Nov 5th 2009 at 10:05 PM

Morii, this topic sames to be related to same problem that this one: http://www.tuxguitar.com.ar/forum/5/1437/1-2-fingerboard-no-strings/

Lets post new comments in this one.

I'll say same as my last post in the other topic.

Try to open with any text editor the file:

(if somebody don't knows.. ~/ means the user's home folder.. e.g: /home/[username]/ )

* It's important to edit this file when tuxguitar is closed.

And try append this line:

Save the file, and run the application..
so does it fix something ?

Back to Top
Post: Nov 6th 2009 at 8:23 AM

Great, great Julian

You're right on everthing (that's why you're the author of this application isn't it ?).

1- I had both TuxGuitar 1.1 & TuxGuitar 1.2 installed on my computer
2- I removed TuxGuitar 1.1 and purge all configuration files
3- I downloaded the Ubuntu package and installed this one
4- I checked that GTK+ version was higher than 2.8.xx
5- I modified the configuration.file with the line you're talking about

And .... It works fine

Thank you very much for advice and knowing

PS : I started to (re)translate the items on my mother tongue (french) because there're lots of errors with the current one. Some parts are not translated and I noticed few mistakes.

Back to Top
Post: Nov 6th 2009 at 12:08 PM

no encuentro en la version linux el fichero que dices el config.properties lo tengo que crear?

Back to Top
Post: Nov 6th 2009 at 12:12 PM

Solucionado otra opcion es abrir el tuxguitar.jar y editar el config.dist que hay dentro del jar y aƱadir la linea que julian indica

solved another option is firtstly open the jar file then edit config.dist file and update it adding the line that julian is telling you

Back to Top
Post: Nov 6th 2009 at 12:44 PM



config.dist ( inside tuxguitar.jar ) is a default configuration file.

~/.tuxguitar-[version]/config.properties is the user's config file ( that overrides default config )

This file is automatically created after launch and close the application.

It's a hidden file. so maybe it's why you don't see it (all starting with "." is a hidden file/folder in GNU/linux.. in this case it's .tuxguitar-[version] )

You should be able to see it with:
cat ~/.tuxguitar-1.2/config.properties

if you don't see it.. it's because you don't have 1.2 version, or you never launched it.

Anyway.. it seems to be a GTK or Cairo problem with "line_to" function and antialias in OFF mode (force-os-defaults, just disable antialiasing changes.. using OS default).
My question is why it could happens.
i installed Ubuntu 9.10 in virtual box yesterday, and i didn't have this problem.
So coult it be related to a hardware/driver thing ?

What video card do you have ?

Back to Top
Post: Nov 6th 2009 at 1:29 PM

mine is intel mobile graphics accelerator 4500M

Back to Top
Post: Nov 11th 2009 at 12:48 AM

Thanks Julian,
adding string to /config.properties made it work.
I'm using Ubuntu 9.1 btw

Back to Top
Post: Nov 13th 2009 at 4:04 PM

I used this command and it works fine

$ echo "painter.force-os-defaults=true" >> ~/.tuxguitar-1.2/config.properties

*just a quick way to Julian's post ;)

Back to Top
Post: Nov 14th 2009 at 4:06 AM

I get Permission Denied when I try that. Am I doing something wronng?

Back to Top
Post: Nov 14th 2009 at 3:07 PM

It's strange to have access denied for this command..
config.properties isn't a read only file..

anyway if you can't use this command.. try manually open it.

If you have gnome:
gedit ~/.tuxguitar-1.2/config.properties

If you have kde:
kedit ~/.tuxguitar-1.2/config.properties

If you have xfce4:
mousepad ~/.tuxguitar-1.2/config.properties

Back to Top
Tukusej's Sirs
Post: Nov 20th 2009 at 5:41 PM


i have got the problem with displaying horizontal lines of the score n the higher 3 strings of the guitar fret (and vertical ones which are part of the note sign). I want to pls U to write me how to correctise it, bu in simply way, cos i'm a newbie in Linux ... i'm using Ubuntu Studio 9.10. i'v installed only the tg 1.2. Thk U in advace.

Back to Top
Post: Nov 21st 2009 at 3:17 PM

I think the most easy way, is that described by anonymous.

Just open a Terminal, type next line and press Enter:
echo "painter.force-os-defaults=true" >> ~/.tuxguitar-1.2/config.properties

But make sure tuxguitar is closed when you do that.

Back to Top
Tukusej's Sirs
Post: Nov 21st 2009 at 6:03 PM

thk U, Julian, veery much ... Unpayable ... ... i love Yr tg much more than gp which i formerly used ...

Back to Top
Jorge Santos
Post: Nov 29th 2009 at 1:05 PM


This works perfectly. Thanks guys
ubuntu 9.10

Back to Top
Jason Blake
Post: Dec 4th 2009 at 12:35 PM

Adding this line:
to this file:

solved the problem, and I've got my Fretboard lines & notes lines!

Great job! Thanx guys specially Julian!

Back to Top
sir thanksalot
Post: Dec 10th 2009 at 8:10 AM

Had the same problem on 9.10 karmic amd64 with an intel X4500 onboard graphics chip in my laptop. I am using compiz on gnome.
Adding "painter.force-os-defaults=true" did the trick for me with tuxguitar 1.2 - Thanks!

Back to Top
Post: Dec 13th 2009 at 4:09 PM

Does all of you have "intel" graphics ??

Back to Top
Post: Dec 13th 2009 at 7:01 PM

It seems related to intel graphics card and Gtk :P

Btw, I also have an Intel integrated graphics 3d card, and I've compiz active by default [ on Ubuntu 9.10].


Back to Top
ruPpY gaRciA
Post: Feb 18th 2010 at 7:34 AM

Thanks, I am finding this way!!

I'm using Ubuntu 9.10 on my laptop, and It's occurred the same problem, too.
It's solved perfectly the problem. Thanx, Julian

Adding this line:
to this file:

Back to Top
Post: Mar 13th 2010 at 11:51 PM

Thanks dude,

I was pullin hairs with this cause it is my favourite tool.

Great program


Back to Top
Post: Mar 21st 2010 at 2:49 PM

I had a similar problem where the note heads weren't displaying. Same config.properties fix worked for me.

System particulars....

Fedora 12

# uname -a
Linux Turing.cabent.org #1 SMP Sat Feb 27 09:42:55 UTC 2010 i686 athlon i386 GNU/Linux

# lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9600 GT] (rev a1)

# tuxguitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version:
-> JVM-Name: OpenJDK Server VM
-> JVM-Version: 14.0-b16
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_0
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-1.6.0-openjdk-
-> Java-Class-Path: ::/usr/share/tuxguitar/tuxguitar.jar:/usr/lib/java/swt.jar:/usr/share/java/itext.jar:/usr/share/tuxguitar/
-> Java-Library-Path: /usr/lib/alliance/lib:/usr/lib/tuxguitar/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/mozilla

BTW. Love the program. Thanks.

Back to Top
Post: Mar 28th 2010 at 8:38 PM

Still having some graphics problems...
1. The tempo and triplet feel icons don't show properly
2. The chord names don't show over the symbols.
3. The note glyphs change to a 'pi' symbol during playback, though any with a modifier (sharp/flat/natural) display correctly.

Back to Top
Post: Mar 29th 2010 at 6:42 PM

What is your SWT version ?
Does it happen with our official releases ?

You can try without install it:

Back to Top
Post: Apr 27th 2010 at 7:59 PM

I have the exact same issue as cbattles posted above with the screenshot. I was missing the note heads before and now get the 'pi' symbols.
Using Mandriva 2010.1 beta with nvidia 8800GTS, driver 195.36.15

uname -a
Linux mjollnir #1 SMP Thu Apr 22 21:49:26 UTC 2010 i686 i686 i386 GNU/Linux

Back to Top
Post: Apr 27th 2010 at 8:05 PM

And yes, I get the same results with the liver java web start version.

Back to Top
Post: May 1st 2010 at 2:48 PM

cbattles and PranQster, could you tell me what GTK version do you have installed ?

Back to Top
Post: May 7th 2010 at 4:01 AM

xlvgzomj http://bdtvrfso.com ztyjcfnc ftskcpvw [URL=http://fdyijkca.com]ixpmurla[/URL] ouopoblm

Back to Top
Post: Sep 10th 2010 at 3:23 AM

xivcsdaj http://czlcsqss.com ghsmxoix wqyarzwa

Back to Top
Post: Sep 10th 2010 at 3:24 AM

zzadgwbg http://njkuguni.com orfozwes ylahrknq

Back to Top