Tux Guitar


Subject tuxguitar and java problem (swt?)

Author Message
Post: Jul 28th 2009 at 5:27 PM

I use Gentoo.
GNU/Linux-x86 Installer and GNU/Linux-x86 Binary Files both give the same error.
GUI installer install file just fine but when I start ./tuxguitar

I get the following error:

$ ./tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3536 or swt-gtk in swt.library.path, java.library.path or the jar file
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

echo ${JAVA_HOME}

ls -lah ${JAVA_HOME}

/etc/java-config-2/current-system-vm -> /usr/lib/jvm/sun-jdk-1.6


java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Server VM (build 14.0-b16, mixed mode)


Let me know if you need any more information to help me solve this problem.

Thank you

Back to Top
Post: Jul 28th 2009 at 7:11 PM

For any reason, swt can't load some native libraries...

So try this:

with the non-installer release (because i don't remember know the startup script of the other :) )

in the folder: tuxguitar-1.1-linux-x86/lib
try open swt.jar with any archive manager (e.g: file-roller)
and extract all .so files in same folder "tuxguitar-1.1-linux-x86/lib"

( swt.jar since 3.3 have the libraries packaged in the jar, and try to extract them on /tmp and load in boot time.. maybe this is failing in your system )

so now, that you have libraries in lib/ folder..
try run tuxguitar again.

if it fails.. see first.. if there is something broken in /tmp ( swt* or libswt* ) and remove it..
then open again swt.jar and remove all .so files inside..

if you still can't solve the problem.. try find how to install SWT in gentoo.. and then modify the script "tuxguitar-1.1-linux-x86/tuxguitar" to use your path/swt.jar instead of lib/swt.jar..

Back to Top
Post: Jul 28th 2009 at 11:09 PM

Thank you
It works now.
/tmp is mounted 'noexec' so this is probably the reason for all the trouble.

BTW, Can you please add 5 string banjo (open G):

1 D5
2 B4
3 G4
4 D4
5 G5 (string starts from 5th fret)
(see http://www.get-tuned.com/banjo-tuning-piano.php)


Back to Top