Tux Guitar


Subject No sound in Debian after deletion of Pulse

Author Message
Post: Jul 20th 2009 at 8:42 PM

Hi. I'm running Tuxguitar on Debian unstable. I had previously been using Pulseaudio, but I had a lot of trouble with it so I deinstalled it throughout, and am now back to ALSA.

Tux guitar is not generating any sound, I'm afraid. Some diagnostics:

I'm using Timidity for MIDI, and this works; that is, typing
$ timidity filename.MID
on the commandline does produce output. In my Timidity conf file I set TIM_ALSASEQPARAMS="-iA -Os".

for aconnect, I get:
$ aconnect -o
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'

I do have the snd_seq module loaded. I can play sound with audacious (for example).

When I start tuxguitar, I get the error "/dev/sequencer: No such file or directory". However I have googled for this and not found anything useful.

In tuxguitar, in my Tools -> Settings -> Sound option, the only MIDI sequencer option is the TuxGuitar Sequencer, and the only MIDI port is the "Midi Through Port-0 [14:0]" option.

What can I do to get this working? I don't know what the /dev/sequencer problem is....


Back to Top
Post: Jul 20th 2009 at 8:56 PM

"/dev/sequencer" is not from tuxguitar-alsa plugin (needed for timidity)..
if could be throwed by tuxguitar-fluidsynth or tuxguitar-oss.. if you have one of thes plugins installed.

if aconnect -o don't display timidity results, it means that your timidity daemon is not running.. so

first make the simple test.. in a terminal
timidity -iA -Os

without close this terminal.. in a newone..
aconnect -o

does it display timidity ports ??
if yes.. you should be able to select them in tuxguitar ( but as MIDI Port.. the MIDI Sequencer is a different thing )

now, i asume this worked..
the next step is check why timidity didn't start with your PC.
check in /etc/default/timidity.
make sure that you have ( uncommented )
(if it's not setted.. or if it's false.. timidity will no start with the init script )..

now check the init script ( as root )
/etc/init.d/timidity start

if it works it must create new ports to alsa ( if you still have running timidity in other terminal.. so on aconnect -8 you must see 8 timidity ports.. )

Back to Top
Post: Jul 20th 2009 at 9:07 PM

Hmm, that's very odd.

Everything you described worked fine. Running timidity -iA -Os and trying aconnect -o in another terminal did display timidity ports, and they were selectable in tuxguitar.

I did have TIM_ALSASEQ=true in my /etc/default/timidity (uncommented).

/etc/init.d/timidity start did start timidity, and from then on starting tuxguitar gave me sound.

I don't know why it's not starting at boot time, though. Will try to explore more.

Oh, I'm still getting the /dev/sequencer error, but I'll remove the OSS plugin, which I don't use, see if that works.

Thank you!

Back to Top
Post: Jul 20th 2009 at 9:34 PM

i think you are having an error at boot time..
try to see the terminal 1: Ctrl + Alt + F1 ( back to X mode with Ctrl + Alt + F7 )

i have on the last line
"Starting Timidity++ ALSA midi emulation"

Do you see any error message there ??

What i tried to say with "/dev/sequencer" thing.. is don't worry about.. it's not a problem..
i don't exactly remember now if it's the tuxguitar-oss plugin, or the tuxguitar-fluidsynth (when try to init oss driver ) but it can't be the reason of your problem.. timidity works for you, the problem is that it don't starts with your PC.

Back to Top