Tux Guitar


Subject No sound in Ubuntu 9.04

Author Message
Post: Apr 28th 2009 at 8:50 AM

TuxGuitar was running nicely in Ubuntu 8.10, thanks to the help in other threads relating to timidity and all.

However, on upgrading to 9.04, there is no sound.

Any hints, anyone?

Cheers - AAM.

Back to Top
Post: Apr 29th 2009 at 4:37 AM

yeah...same problem

Back to Top
Post: Apr 29th 2009 at 8:19 AM

Glad to know I'm not the only one... am trying different stuff but not getting a result.

There's no error in tail dmesg yada yada yada so it's a bit confusing.

Halp? Anyone?

Back to Top
Post: Apr 29th 2009 at 12:20 PM


Same problem here - freshly installed Ubuntu Jaunty and the sound doesn't work. I installed Timidity++ and re-installed the Sun JDK runtime but still no luck.

BTW - The version available in "add / remove" looks older than the one available here, but both don't work.

Back to Top
Post: Apr 30th 2009 at 9:37 AM

In fact, I discovered that it depends on the files. Some files are working fine but others aren't.

I can send 2 examples if someone wants to look at them.

Back to Top
Post: Apr 30th 2009 at 10:49 PM

Problem solved...
install tuxguitar 1.1 from here


Back to Top
Post: May 1st 2009 at 12:50 AM

Hmmm - the package gives the error:

Error: Breaks exisiting package 'tuxguitar-fluidsynth' dependency tuxguitar (= 1.0.dak-1ubuntu1).

So, I used Synaptic to completely remove all tuxguitar files and installed the new package.

Same result - no sound.

Did timidity -iA -Os &. Timidity reported port 130:0 and others, changed the settings in tuxguitar and hurrah! sound at last.

I closed it and restarted and the port number had incremented to 131. :-/

I hope there can be a more elegant fix than having to launch timidity manually every time.

Back to Top
Post: May 5th 2009 at 1:31 PM

There are ways to automatically start timidity.
the problems started with pulseaudio.
now some people can't make timidity run at startup with pulseaudio together.

After buy hardware for a new PC, i had similar problems
under Debian testing -> pulseaudio -> timidity.

I posted here how did i fix it:

But, as i told on that post, it's for people that have same config as i have ( running pulseaudio and timidity from init.d scripts )
if you have pulseaudio daemon running as "autostarted" application on your desktop, that will not be the solution.

Back to Top
Lars, Norway
Post: May 7th 2009 at 12:42 PM

I made mine work! Had the same problem as the first posts claimed. I don't know what innstallations exactly made it work, but I searched other threads in the Ubuntuforum, and here's what I did:

I innstalled Timidity via the application innstaller (Think it's called "add/remove applications", and it's located in the programs tab on your desktop) After this, i innstalled all the packages for tuxguitar in synaptics [search: "tuxguitar"] (tuxguitar, tuxguitar-alsa and tuxguitar-oss were already innstalled)

Then, I applied some changes in Tuxguitar [Tools>Settings>Sound] I changed the MIDI sequencer from TuxGuitar Sequencer to Real Time Sequencer. That option was not there before I innstalled the packages. I also changed the MIDI port to Gervill, which was also not available before I innstalled the packages.

After closing the settings menu, and applying the changes (prompted when exiting the menu), I had sound!

Hope this works for others. I'm a bit of a newb in computing, but this worked for me.

Back to Top
Post: May 13th 2009 at 5:02 PM

I had the same problem as you, but I solved it by installing Sun jre 1.6 and a soundbank in /usr/lib/jvm/java-6-sun-
You can find there
It worked for me I hope it will work for you as well.

Back to Top
Post: May 29th 2009 at 8:19 PM


Your solution worked in my case, I had some issues with alsa after a clean install of Jaunty and this is icing on the cake thank you for your post.

Back to Top
Post: Jun 3rd 2009 at 4:22 PM

I've installed tuxguitar 1.1 correctly but i've still no sound

Back to Top
ezz, grimsby
Post: Jun 4th 2009 at 4:53 PM

I had no sound with 8.10 but followed Lars, Norway's tip (except in Tuxguitar [Tools>Settings>Sound] I set the Midi port to 'Java Sound Synthesizer' because I didn't have Gerbil as an option in mine).

Thanks Lars

Back to Top
Post: Jun 27th 2009 at 2:18 AM

Right tip Lars!! thanks

Back to Top
Post: Jul 26th 2009 at 3:48 PM

Thanx Lars, I'v searched for that solution for a while (since I'v installed Jaunty.....)

Back to Top
Post: Jul 26th 2009 at 5:25 PM

Great work Lars, appreciate it.

Back to Top
Bruno Canongia
Post: Jul 29th 2009 at 2:24 PM

to allow java in sound settings
apt-get install tuxguitar-jsa

Back to Top
Bruno Canongia
Post: Jul 29th 2009 at 2:30 PM

If you receive the "midi system unvailable" msg.
Install the "alsa-aoss" package and start tuxguitar with
aoss tuxguitar

Back to Top
Post: Jul 29th 2009 at 8:19 PM

Lars, you're my hero! Thank you so much!

Back to Top
Post: Jul 29th 2009 at 8:42 PM

Ok, after a test with [url]http://www.ultimate-guitar.com/tabs/n/nofx/franco_un-american_ver2_guitar_pro.htm[/url], it turned out that it didn't really work good. When there are more then 5 or 6 instruments, the sound is acting quite strange, a bit like playing all the notes at the same time, and sometimes when I pause it, I get a sound that just keeps going, it sounds almost like an american truck horn.

Does anyone know what the problem is or how to solve it?

Back to Top
Mike Lopantoni
Post: Jul 30th 2009 at 7:38 AM

Lars, now. i don't need Windows anymore, thanks to you. Cheers from Mexico

Back to Top
random guy
Post: Aug 3rd 2009 at 3:41 PM

Thx a lot to
Lars, Norway
Post: May 7th 2009 at 9:42 AM.
Now sound works perfectly fine for me, using ubuntu 9.04 x64.

Back to Top
Post: Aug 5th 2009 at 9:09 AM

Thanks Bruno Canongia. It works fine now.

Back to Top
Post: Aug 9th 2009 at 9:51 PM

Thanks Lars your advice worked great!

Back to Top
r@ul (argentina)
Post: Aug 10th 2009 at 11:14 PM

Now works well, thanks Bruno

Back to Top
Post: Aug 11th 2009 at 4:15 AM

Lars, you're great!!! greetings from Venezuela!

Back to Top
Post: Aug 11th 2009 at 8:35 AM

it works!!!!!thanks lars

Back to Top
Post: Aug 13th 2009 at 3:12 PM

thx Lars

Back to Top
Post: Aug 21st 2009 at 4:35 PM

thanks everybody for the help...i had the same problem...
see you later

Back to Top
Post: Aug 29th 2009 at 4:52 PM

All I did was install all of the packages, and after that it worked perfectly for me!

Back to Top
Post: Sep 6th 2009 at 9:29 AM


I had no sound on mscore, which has fluidsynth integrated. I had no sound on timidity either. Also jack and the standalone fluidsynth did not work. I followed the suggestions from the earlier posts here. And got sound.

Then I found that Ubuntu ran timidity as as server automatically. I used System -> Administration -> BootUp-manager, and disabled the automatic timidity server. Then mscore, fluidsynth and timidity worked.

The worst thing I see is "It worked for me". It is not at all helpful but rather extremely provocative for us for whom it does not work.


Back to Top
Post: Sep 12th 2009 at 3:12 PM

One of the problems with timidity.. is that it don't have pulseaudio support.. and now, allmost distributions came with pulseaudio as default.
it causes that sometimes (or for some users depending the hardware ) timidity can't run with ALSA at same time as pulseaudio.. and it also cause problems later..

now fluidsynth have pulseaudio support.

About jack output, it's a similar story.. if you can run pulseaudio through jack, all works fine.. but if you try to run pulseaudio, and jack through ALSA together, you'll find also problems..

Back to Top
jorge figueroa
Post: Sep 18th 2009 at 5:10 AM

Great!!!!! thanks lars by the way synaptics is part of the operating system, not a website look for it. i have ultimate edition 2.2 running and the proses that lars used works!!! thanks a lot. now i can completely say bye bye to windows. Also for this os users try wine for windows installations in this operative system its great.

Back to Top
Jack Elliott
Post: Oct 8th 2009 at 5:44 PM


Thanks very much mate, problem solved for me too.

Why isn't 1.1 in the repos?


Back to Top
Post: Oct 10th 2009 at 3:58 PM

1.1 is under latest ubuntu repositories
maybe you don't have latest ubuntu version.
it's normal that if you have an old version, tuxguitar 1.1 didn't exists when ubuntu was released. so ofcourse it couldn't be included.

Back to Top
Post: Dec 7th 2009 at 12:51 PM

how do i install the packages for real time sequencer and MIDI port to gervill? :S

Back to Top
Post: Dec 13th 2009 at 4:02 PM

aelfric, first you must to have tuxguitar-jsa (java sound api) plugin installed.
then you must make sure that tuxguitar is running with openJdk

Back to Top
Post: Mar 14th 2010 at 4:30 AM

we love lars, lars rocks, thanks mate, rene and luc in australia

Back to Top
Post: Oct 26th 2011 at 5:14 AM

Thanks a lot Lars, i was about to give up Tux, but it's working very well right now... i didn't knew we needed Timidity to use Tuxguitar, now i've installed, all i needed to do was select Timidity port: 0 to hear my tab.

Peace guys! and thanks again!

Back to Top
Alessandro - Italy
Post: Dec 29th 2011 at 4:39 PM

Thank you Lars! Still asking why it works, but it does!

Back to Top