Tux Guitar


Subject Mac - Can't Open TuxGuitar anymore

Author Message
Post: Feb 1st 2009 at 12:31 AM

My setup:
I have a MacBook Pro Running OS X 10.4.11
also this might be unrelated but i have dropped it a few times and one corner is sticking up and the CD Drive didnt work for a long time as well the Genius's at the apple store couldn't fix it they said i would have to take it to get fixed somewhere but repairs would cost a lot so i never got it fixed and then i did something in my sleep and it started working again.

I downloaded tux guitar mor mac 6 months ago and it worked perfectly fine, other than some minor problems with editing the size of the fonts for viewing and printing, anyways the problem is it simply wouldn't open; the icon would pop up in my tray and then would close after a second.

It did this for 3 months and then I got fed up and deleted it from my applications folder and then reinstalled it and it did the same thing so I deleted it again.

Today I re-downloaded it and opened the dmg file. I double clicked it in the mounted image and the icon still pops up in the tray but doesnt stall anymore just opens then closes way faster. I then dragged the app into my applications folder and the same thing happened just even faster.

All i want to be able to do is use TuxGuitar again. If someone knows how to fix it please let me know or, they could update the TuxGuitar for mac since it is still only 1.0 currently.

Back to Top
Post: May 11th 2009 at 2:11 PM

same with me =( well i have never used tuxguitar but it just wont open on my mac so im looking for a guide to fix it -.-

Back to Top
Post: Sep 1st 2009 at 2:29 AM

it worked for me on 10.5 but now it wont work on 10.6

Back to Top
Post: Sep 18th 2009 at 1:31 AM

Same with me. I have exactly the same problem. Please help!!

Back to Top
Post: Sep 19th 2009 at 6:45 AM

I am on 10.6 and as well, it won't open (1st time user)

Back to Top
Post: Sep 19th 2009 at 7:04 AM

Hi Guys.

This seems to be a problem with the 64-bit JVM.

jens-mac:MacOS jens$ ./tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.(Unknown Source)
at org.eclipse.swt.widgets.Display.createDisplay(Unknown Source)
at org.eclipse.swt.widgets.Display.create(Unknown Source)
at org.eclipse.swt.graphics.Device.(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

Back to Top
Post: Sep 19th 2009 at 10:49 AM


I can't test ist right now, but this should work:
1. Open the terminal
2. cd /Applications/tuxguitar.app/Contents/MacOS/
3. java -d32 ./tuxguitar

Back to Top
Post: Sep 19th 2009 at 10:57 AM

tried what you suggested, here's what I get:

Exception in thread "main" java.lang.NoClassDefFoundError: //tuxguitar
Caused by: java.lang.ClassNotFoundException: ..tuxguitar
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:319)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:330)
at java.lang.ClassLoader.loadClass(ClassLoader.java:254)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:399)

Back to Top
Post: Sep 19th 2009 at 11:36 PM

for anybody wondering how to use tuxgutiar in snow leopard, go to the utilities folder, open up java preferences, in the SECOND box drag the "32- bit" above the 64 bit and it will work, but you have to open up the tabs manually (file>open>)

Back to Top
Post: Sep 20th 2009 at 5:41 AM

Thank you man.

Back to Top
Post: Sep 22nd 2009 at 11:53 AM

Please, follow this topic:

Back to Top