Tux Guitar


Subject org.eclipse.swt.SWTError (swt-mozilla-gtk-3448)

Author Message
Ben Engbers
Post: Jan 28th 2009 at 10:33 PM

I am running TuxGuitar 1.0 on Fedora Core 7.

If I try to use the Help/Documentation, I recieve the following message "org.eclipse.swt.SWTError: No more handles [MOZILLA_FIVE_HOME='/usr/lib/mozilla'] (java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3448 or swt-mozilla-gtk in swt.library.path, java.library.path or the jar file)"
After downloading swt-3.4-gtk-linux-x86.zip, I have tried to set LD_LIBRARY_PATH to the directory where I extracted the SWT, I added swt.jar to CLASSPATH, I extracted libswt-mozilla-gtk-3448.so to /usr/lib/mozilla but nothing helps. I still can't use the documentation (allthough Tuxguitar seems to be working fine:-(

How should I install SWT or edit the tuxguitar startup file?

Back to Top
Post: Jan 29th 2009 at 11:12 AM

I don't thing the problem is SWT don't found "libswt-mozilla-gtk-3448.so"
if you downloaded official "swt-3.4-gtk-linux-x86.zip" file, *.so files are inside swt.jar, and are extracted to "/tmp" at load time.
I thing that maybe this library can't be initialized for any reason, and SWT show the known "not found" error.

Maybe the problem is here:

Last time i tested it, it didn't work for me..
i don't have "modilla" browser installed, but yes have a folder /usr/lib/mozilla (maybe created by firefox or epiphany ) so it makes confutions when you try to set the var.

on my case, i have:

So, if you have firefox you can test it.
export MOZILLA_FIVE_HOME=/usr/lib/firefox

Or, edit the startup file..

i'm not sure if the packager of fedora added it..
try see the startup script if it "add" to LD_LIBRARY_PATH

Or add this line:

the issue is that SWT, not only needs MOZILLA_FIVE_HOME setted.. it also need this path added to LD_LIBRARY_PATH

I hope it helps

Back to Top
Ben Engbers
Post: Feb 4th 2009 at 2:00 PM


I made a symbolic link (/usr/lib/firefox) to /usr/lib/firefox- and that solved theproblem.


Back to Top