Tux Guitar


  Forums : Help
Subject no sound

Author Message
Post: Aug 20th 2006 at 6:27 PM

Hi ive downloaded the program and its really great, but i am having problems with 2 things, firstly no sound [ive checked the usual hardware things] and second i cant get any instruments to show in the properties tab they its just greyed out, can anyone help please?

Back to Top
Post: Aug 21st 2006 at 12:12 AM

Hi.. maybe your java virtual machive don't have a soundbank installed.
check in your java installation path:
if this file doesn't exists.. download a soundbank file from:

Back to Top
Post: Aug 21st 2006 at 4:24 PM

Thanks, dowloaded and working, great program

Back to Top
Post: Oct 18th 2006 at 1:45 AM

fixing my error:
i say:
but it is wrong.. the folder is not "sound", it is "audio"

Back to Top
Post: Nov 3rd 2006 at 6:59 AM

I had the same pb ! Thank U very much !!! (love this program ^^)

Back to Top
Post: Feb 17th 2007 at 11:01 PM

Yep fixed it 4 me, very helpful

Back to Top
Post: Mar 21st 2007 at 9:12 PM

Didn't help me :( I have the best sound bank installed, and there is no error as far as I can tell, I just have no sound.. It says its playing, my speakers are plugged in, and the volume is up! (I can listen to music...)

I just can't hear my GP5's! Argh! I'd really appreciate some help... Also, I'm running 0.9.1 and it doesn't install, is that right? It just runs from the extracted file?

Cheers :D Rohan

P.S. I'm running FC5 if it helps...

Back to Top
Post: Mar 22nd 2007 at 11:09 AM

if you run the app on a terminal...
do you see any error log when you try playing???

Back to Top
Post: May 20th 2007 at 2:08 PM

how can i install this damn sound bank step by step
without any trix

Back to Top
Post: May 25th 2007 at 5:46 PM

I'm really sorry to bother you, but I've tried some of the suggested fixes and nothing seems to work.

Tux Guitar loads beautifully. I downloaded the deluxe-soundbank.gm from Sun and installed it into the correct directory.

I tried running it with the alsa wrapper (aoss tuxguitar).

I tried launching both of these configurations from bash to watch for output and there was none.

Anymore suggestions?


Back to Top
Post: May 25th 2007 at 6:04 PM

Hi, if you don't see any error log, the soundbank is not your problem.. ( soundbank problem, throws "Unavailable soundbank error" when it happends)

i assume your problem is "you can't listen sounds".. and there is no error log.

please, say me some things:
1_ what dist of tuxguitar do you have? ( .deb, .tar.gz, .exe..)

2_ do you have installed tuxguitar-alsa plugin ???... you can check it at tuxguitar menu "Plugins" (plugins menu is hidden if you don't have plugins)
if its true, tuxguitar will play sounds with a native alsa port.. so you need configure the plugin to run it with any software synthesizer (like timidity).. or disable it.. to play sounds with Java Sound Api + soudnbanks.

3_ if you are under linux, please paste here the result of "lsmod | grep snd_seq"

Back to Top
Post: May 25th 2007 at 7:57 PM

Hi Julian,

Thanks for the response.

I downloaded the v0.9.1 bin file. There is no plugin option on the menu.

The output of lsmod | grep snd_seq is nothing. However, the output of lsmod alone shows many snd-* modules loaded.

Anyway, I downloaded the tuxguitar-alsa plugin. There's no documentation with the file. How and where would I install it?

Thanks again,

Back to Top
Post: May 26th 2007 at 12:02 PM


about "snd-":
look, i see on the web, some people use "-", and other "_" (my case).. but i'm not sure why.. so.. if "snd_seq" don't have results, try "snd-seq"...

lsmod | grep snd
you must have "snd-seq" or "snd_seq".. if you don't have that module loaded, you will need load it.
as root:
modprobe snd-seq (or snd_seq)

about "tuxguitar-alsa":

well, if you downloaded "TuxGuitar-alsa-0.9-linux-gtk-x86"
you must copy the content of TuxGuitar-0.9-linux-gtk-x86/ in to the tuxguitar installation folder..

cd TuxGuitar-alsa-0.9-linux-gtk-x86

cp TuxGuitar-0.9-linux-gtk-x86/lib/* /whereis/tuxguitar-0.9/lib

mkdir /whereis/tuxguitar-0.9/share/plugins
cp TuxGuitar-0.9-linux-gtk-x86/share/plugins/* /whereis/tuxguitar-0.9/share/plugins/

ofcourse, you must replace "whereis" to the path of your tuxguitar installation folder.

then, when you launch tuxguitar you will see a new menu "plugins".. and you must set a valid alsa midi device to play sounds... i suggest you install timidity or fluidsynth (fluidsynth is nice, but you need search and download soundfonts to make it work)

Back to Top
Post: May 26th 2007 at 3:17 PM

Hi Julian,

I followed your instructions for copying the contents into the tuxguitar directory. Now I receive this error when loading Tux Guitar.

java.lang.UnsatisfiedLinkError: /home/dan/tuxguitar-0.9.1/lib/libMidiReceiverJNI.so: /lib/libc.so.6: version `GLIBC_2.4' not found (required by /home/dan/tuxguitar-0.9.1/lib/libMidiReceiverJNI.so)

Do I need to update something on my system?

Back to Top
Post: May 26th 2007 at 3:21 PM


lsmod | grep snd outputs this:

snd-seq-oss 23104 0 (unused)
snd-seq-midi-event 3208 0 [snd-seq-oss]
snd-seq 33552 2 [snd-seq-oss snd-seq-midi-event]
snd-seq-device 3716 0 [snd-seq-oss snd-seq]
snd-pcm-oss 28928 0
snd-mixer-oss 11928 0 [snd-pcm-oss]
snd-maestro3 14052 0
snd-ac97-codec 68160 0 [snd-maestro3]
snd-pcm 52804 0 [snd-pcm-oss snd-maestro3 snd-ac97-codec]
snd-timer 13168 0 [snd-seq snd-pcm]
snd 34304 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-seq-device snd-pcm-oss snd-mixer-oss snd-maestro3 snd-ac97-codec snd-pcm snd-timer]
snd-page-alloc 4980 0 [snd-seq-oss snd-seq snd-seq-device snd-mixer-oss snd-pcm snd-timer snd]
soundcore 3300 5 [snd]

Hope that helps,

Back to Top
Post: May 26th 2007 at 3:41 PM


well... snd_seq is already loaded.. so nots the problem.

about: java.lang.UnsatisfiedLinkError......
this is because you have a less version of libc than the used to build the plugin..

>Do I need to update something on my system?
i don't think so.. to upgrade libc, you need upgrade a lot of dependences.

so, you should build the plugin from sources to your system.

do this to build the plugin:

# download the sources

# untar the sources
tar xfz TuxGuitar-alsa-0.9-src.tar.gz
cd TuxGuitar-alsa-0.9-src

# edit build.properties with any text editor.
# and set the correct paths of TuxGuitar.jar and swt.jar

# build the sources
#to launch "ant", make sure you have installed
# "jdk", "ant" and "libasound headers"

then copy the files plugin_tuxguitar-alsa.properties,TuxGuitar-alsa.jar,libMidiReceiverJNI.so
with the same structure as you did before..

Back to Top
Post: May 26th 2007 at 4:23 PM


Right now, Sun is having problems with their downloads, so I can't get the JDK. Besides, my linux machine is only PIII 600MHz with 256MB RAM. However, I do have the latest JDK, as well as netbeans, on my Windows XP box and Mac OS X box. Can I build the source on any of those two machines and transfer it to my Linux box?

Thanks for all of your help,

Back to Top
Post: May 26th 2007 at 4:51 PM

yes but not :p...

tuxguitar-alsa uses JNI (Java Native Interface)..
so its a .jar (with java classes) and a .so (linux native library)
you can build the jar under win, because its multiplatform..
but you can't build the .so file...

your problem here.. is only the .so .. you need build only the libMidiReceiverJNI.so with your libc..
you can make it without call "ant".. but you'll need jni headers what are at JDK. (maybe you can use GCJ headers.. but i'm not sure of that)

if you want try build only the .so, the sources are at:
it should build with "make"...

Back to Top
Post: May 26th 2007 at 8:12 PM


I'm so dumb. It was a permissions issue.

Thank you for all of your help!


Back to Top
Christian Louboutin Wedding Shoes
Post: Apr 17th 2012 at 8:17 AM

Even the packaging around the Christian Louboutin Barbie Shoes Christian Louboutin Ankle Boots is exciting. Each pair of shoes comes in a tiny little box and includes a shoe bag for Cheap Louboutin Sneakers each Christian Louboutin Wedding Shoes pair. No self-respecting owner would want to hide these out of sight, so these nine pairs of Cheap Louboutins fabulous shoes come with a 13-inches tall x 10-inches wide x 3-inches long display box. Best of all, this entire collection can be purchased for less than $60! I wish I could find nine pairs of stunning Louboutin shoes for that price, for my big old human Cheap Louboutin Pumps feet! At that price, this collection is an ideal gift for the Barbie enthusiast's special occasion

Discount Louboutins

Back to Top