Tux Guitar


  Forums : Help
Subject No sound when playing tuxguitar on Ubuntu 8.10

Author Message
Post: Feb 11th 2009 at 7:06 AM


I went through trough the other posts and tried everything without success; there is no sound when playing the Tuxguitar and there is no message too.

In Tools->Settings->Sound there are:
Midi thoutgh Port 0-#0
TiMidiTy Port 0-#1 through 3- #4
Midi thoutgh Port [14:0]
TiMidiTy Port 0 [128:0] through 3 [128:3]
Java Sound Synthesizer

I tried all the above without success.
I tried both the Realtime and Tuxguitar Sequencers.

The sound works OK with other programs.

Any inputs are greatly appreciated.


Back to Top
Post: Mar 28th 2009 at 4:55 PM

Yeah i'm having te same problem in ubuntu 8.10

Back to Top
Post: Mar 28th 2009 at 6:02 PM

Could it be, that another program is "blocking" tuxguitar?

I encountered a similar problem. Firefox and Tuxguitar could not have sound at the same time.


Back to Top
Post: Mar 28th 2009 at 6:39 PM

it's strange that since hardy ( and pulse audio inclussion )
timidity and fluidsynth stopped work for a lot of users.

I don't have the exactly answer, because i can't reproduce the problem on my machine.

but, i can suggest you some things.

* make sure that timidity is running with alsa output.
paste me the result of "ps ax | grep timidity"
Or test start a new instance of it:
~$ timidity -iA -Os
Without close the terminal where you started timidity
now try select the first of new timidity ports ( often times 129:0 )

* try with fluidsynth if you can't make timidity run.

Iron, yes it happens if you have "Java Sound Synthesizer" selected.
it's a known issue of the java sound api described here:

we have to add to this document about "padsp" too.
that it is something like "alsa-oss" but for pulse audio.

If you have pulseaudio server running, you can run tuxguitar as:
padsp tuxguitar

and pulseaudio wil capture the java sound synthesizer output and wrap it as a pulseaudio plugin. (it's supposed you'll not have the OSS emulation conflicts when any other sound device is opened )

Back to Top
Steven Sproat
Post: Apr 5th 2009 at 5:06 PM

Wow!!! Thanks for that post, Julian, installing timidity and selecting its port worked -perfectly-

Now I don't have to boot to windows to play tabs! Thanks so much

Back to Top
Post: Apr 26th 2009 at 9:50 PM

I dont quite understand how to make sure timidity is using the alsa output how to i check/change thiS?

Back to Top
Post: Apr 29th 2009 at 6:02 PM

Go to "Tools -> Settings", and on sound tab you can look for MIDI Port option.
if timidity is selected, so you are using it.

Back to Top
Post: May 10th 2009 at 2:45 AM

installing timidity and setting it to work in the tools/sound section also works on 9.04

Back to Top
Post: Jun 22nd 2009 at 10:14 PM

But i have to run this command "~$ timidity -iA -Os" every time i boot the machine. How can i automatize that?

Back to Top
Post: Jun 29th 2009 at 4:06 PM

You can make a script that exec this command, and add it to your autostarted applications

Back to Top
Post: Jul 21st 2009 at 10:35 AM

thanx for the timidity tip!
i otherwise always used to export to midi and then play it in a player!

Back to Top
Post: Nov 16th 2009 at 11:34 PM

Thankyou SO much for that tip, Julian. I just solved a problem in Processing that had me stumped for the entire day! Minim and GStreamer now work beautifully together!

Back to Top
Post: Mar 16th 2011 at 11:16 AM

altho i havent posted my problems on any of these blogs.... i have been following the timidity and tuxguitar issue blogs throughout, and finally have come to a working tuxguitar application. thanks Jullian really appreciated. All of the other sollutions didnt work for me but this particular (timidity -iA -oS) one did... wonder why...???

Back to Top
Post: Mar 16th 2011 at 11:17 AM

For the record... i am using Ubuntu Meerkat Maverick... forgot the version code.

Back to Top